# CVE-2026-24137: sigstore legacy TUF client allows for arbitrary file writes with target cache path traversal

> A malicious TUF repository can overwrite arbitrary files via path traversal in the legacy TUF client's target caching mechanism.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2026
- **Updated:** 23 Jan 2026
- **Also known as:** CLEANSTART-2026-LE66959, CLEANSTART-2026-UR24822, DEBIAN-CVE-2026-24137, GHSA-fcv2-xgw5-pqxf, GO-2026-4358, MINI-2xr2-m35j-74cf, MINI-3jjq-p69x-7m48, MINI-3q4g-g394-w5v9, MINI-43j2-jh5m-w9hj, MINI-4rc5-jq6p-7338, MINI-5p2v-56g7-85hg, MINI-5q48-4g4f-7fh3, MINI-5wqx-x3g6-3xh5, MINI-632h-3j7v-4vrf, MINI-6g3g-52m8-2jpq, MINI-84g5-p6q3-gx4w, MINI-84q3-6qpf-gvgx, MINI-85h3-x3xh-639x, MINI-8697-m9wp-q8cw, MINI-g95x-fhj7-xmp5, MINI-h47p-5fcj-7w32, MINI-h7xv-rg9m-f5xj, MINI-hfch-3hrg-cfc9, MINI-j7f2-xr5g-42h2, MINI-mvmc-mqm2-pmcg, MINI-p3q2-32rc-hh4x, MINI-phpw-vfgv-grvx, MINI-pvjr-2q66-f8pm, MINI-q2jp-4rc6-jgg5, MINI-qrxp-5r27-7p2r, MINI-v8v9-vhqc-mjv4, MINI-vjjw-vw7w-wjpx, MINI-wp67-g4vh-93qx, MINI-xh7m-8p2m-xv2f, MINI-xhhv-gqvq-q4jm, MINI-xm6h-q9vq-hvvv, MINI-xvmg-j8h4-rj57, UBUNTU-CVE-2026-24137

## What is CVE-2026-24137?

CVE-2026-24137 is a medium-severity path traversal vulnerability in sigstore, published on 23 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

sigstore framework is a common go library shared across sigstore services and clients. In versions 1.10.3 and below, the legacy TUF client (pkg/tuf/client.go) supports caching target files to disk. It constructs a filesystem path by joining a cache base directory with a target name sourced from signed target metadata; however, it does not validate that the resulting path stays within the cache base directory. A malicious TUF repository can trigger arbitrary file overwriting, limited to the permissions that the calling process has. Note that this should only affect clients that are directly using the TUF client in sigstore/sigstore or are using an older version of Cosign. Public Sigstore deployment users are unaffected, as TUF metadata is validated by a quorum of trusted collaborators. This issue has been fixed in version 1.10.4. As a workaround, users can disable disk caching for the legacy client by setting SIGSTORE_NO_CACHE=true in the environment, migrate to https://github.com/sigstore/sigstore-go/tree/main/pkg/tuf, or upgrade to the latest sigstore/sigstore release.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-24137?

3 open source packages ship an affected version, including github.com/sigstore/sigstore.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/sigstore` | Go | All versions | 1.10.4 |
| `github.com/sigstore/sigstore` | Go | All versions | 1.10.4 |
| `github.com/sigstore/sigstore` | Go | All versions | 1.10.4 |

## How do I fix CVE-2026-24137?

Upgrade github.com/sigstore/sigstore to 1.10.4 or later.

## Is CVE-2026-24137 being exploited?

There is no known exploitation of CVE-2026-24137 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24137 and fix it if it is affected.

What it is: CVE-2026-24137 is a medium-severity path traversal vulnerability in sigstore, published on 23 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24137 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/sigstore (Go): affected all versions; fixed in 1.10.4
- github.com/sigstore/sigstore (Go): affected all versions; fixed in 1.10.4
- github.com/sigstore/sigstore (Go): affected all versions; fixed in 1.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24137/ (Markdown: https://insights.sbomify.com/CVE-2026-24137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24137
- OSV: https://osv.dev/vulnerability/CVE-2026-24137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24137/
Summaries are generated and may contain mistakes; the official description above is the record.
