# CVE-2026-24159: NVIDIA NeMo Framework contains a vulnerability leading to Remote Code Execution

> Attackers can achieve remote code execution and privilege escalation in NVIDIA NeMo Framework via unsafe deserialization.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-v7v2-m736-cf3c, PYSEC-2026-2675

## What is CVE-2026-24159?

CVE-2026-24159 is a high-severity unsafe deserialization vulnerability in NVIDIA NeMo Framework, published on 24 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NVIDIA NeMo Framework contains a vulnerability where an attacker may cause remote code execution. A successful exploit of this vulnerability might lead to code execution, escalation of privileges, information disclosure and data tampering.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-24159?

3 open source packages ship an affected version, including nemo-toolkit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nemo-toolkit` | PyPI | All versions | 2.6.2 |
| `nemo-toolkit` | PyPI | All versions | 2.6.2 |
| `nemo-toolkit` | PyPI | All versions | 2.6.2 |

Products: Nvidia Nemo.

## How do I fix CVE-2026-24159?

Upgrade nemo-toolkit to 2.6.2 or later.

## Is CVE-2026-24159 being exploited?

There is no known exploitation of CVE-2026-24159 in the wild and no public exploit code.

## Other vulnerabilities in NVIDIA NeMo Framework

- [CVE-2024-0081](https://insights.sbomify.com/CVE-2024-0081/): Denial of service in NeMo (high 8.6)
- [CVE-2025-33245](https://insights.sbomify.com/CVE-2025-33245/): NVIDIA NeMo Framework contains a vulnerability where malicious data could cause remote code execution (high 8.0)
- [CVE-2026-24252](https://insights.sbomify.com/CVE-2026-24252/): Command injection in NeMo Framework (high 7.8)
- [CVE-2026-24155](https://insights.sbomify.com/CVE-2026-24155/): Code injection in NeMo Framework (high 7.8)
- [CVE-2026-24228](https://insights.sbomify.com/CVE-2026-24228/): Deserialization in NeMo Framework (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24159 and fix it if it is affected.

What it is: CVE-2026-24159 is a high-severity unsafe deserialization vulnerability in NVIDIA NeMo Framework, published on 24 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24159 in the wild and no public exploit code.

Affected packages and fixed versions:
- nemo-toolkit (PyPI): affected all versions; fixed in 2.6.2
- nemo-toolkit (PyPI): affected all versions; fixed in 2.6.2
- nemo-toolkit (PyPI): affected all versions; fixed in 2.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24159/ (Markdown: https://insights.sbomify.com/CVE-2026-24159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24159
- OSV: https://osv.dev/vulnerability/CVE-2026-24159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24159/
Summaries are generated and may contain mistakes; the official description above is the record.
