CVE-2026-24343 Apache HertzBeat: Uncontrolled Resource Consumption via Crafted XPath Expressions

High 8.8 Published Updated

Attackers can cause denial of service in Apache HertzBeat by submitting crafted XPath expressions that consume excessive resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-24343?

CVE-2026-24343 is a high-severity denial of service vulnerability in Apache HertzBeat, published on 10 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Neutralization of Data within XPath Expressions ('XPath Injection') vulnerability in Apache HertzBeat.

This issue affects Apache HertzBeat: from 1.7.1 before 1.8.0.

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Weakness: CWE-643

Which versions are affected by CVE-2026-24343?

It affects 1 product.

Products include Apache Hertzbeat.

How do I fix CVE-2026-24343?

No fix has been published for CVE-2026-24343 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-24343 being exploited?

There is no known exploitation of CVE-2026-24343 in the wild and no public exploit code.

Sources

Also known as GHSA-jr4c-vcm8-65vh.

Is CVE-2026-24343 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free