# CVE-2026-24343: Apache HertzBeat: Uncontrolled Resource Consumption via Crafted XPath Expressions

> Attackers can cause denial of service in Apache HertzBeat by submitting crafted XPath expressions that consume excessive resources.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-jr4c-vcm8-65vh

## What is CVE-2026-24343?

CVE-2026-24343 is a high-severity denial of service vulnerability in Apache HertzBeat, published on 10 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Data within XPath Expressions ('XPath Injection') vulnerability in Apache HertzBeat.

This issue affects Apache HertzBeat: from 1.7.1 before 1.8.0.

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Weakness: CWE-643 (Improper Neutralization of Data within XPath Expressions)

## Which versions are affected by CVE-2026-24343?

It affects 1 product.


Products: Apache Hertzbeat.

## How do I fix CVE-2026-24343?

No fix has been published for CVE-2026-24343 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-24343 being exploited?

There is no known exploitation of CVE-2026-24343 in the wild and no public exploit code.

## Other vulnerabilities in Apache HertzBeat

- [CVE-2023-51388](https://insights.sbomify.com/CVE-2023-51388/): HertzBeat AviatorScript Inject RCE (critical 9.8)
- [CVE-2023-51389](https://insights.sbomify.com/CVE-2023-51389/): HertzBeat SnakeYAML Deser RCE (critical 9.8)
- [CVE-2023-51653](https://insights.sbomify.com/CVE-2023-51653/): Hertzbeat JMX JNDI RCE (critical 9.8)
- [CVE-2025-24404](https://insights.sbomify.com/CVE-2025-24404/): Apache HertzBeat (incubating): RCE by parse http sitemap xml response (high 8.8)
- [CVE-2025-48208](https://insights.sbomify.com/CVE-2025-48208/): Apache HertzBeat (incubating): Jmx JNDI injection vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24343 and fix it if it is affected.

What it is: CVE-2026-24343 is a high-severity denial of service vulnerability in Apache HertzBeat, published on 10 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24343 in the wild and no public exploit code.

Affected product: Apache HertzBeat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24343/ (Markdown: https://insights.sbomify.com/CVE-2026-24343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24343
- OSV: https://osv.dev/vulnerability/CVE-2026-24343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24343/
Summaries are generated and may contain mistakes; the official description above is the record.
