CVE-2026-24399 ChatterMate has Stored Cross-Site Scripting (XSS) via Chatbot Input Execution

Critical 9.3 Published Updated

Attackers can execute malicious scripts via chat input to steal sensitive client-side data like tokens and cookies.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-24399?

CVE-2026-24399 is a critical cross-site scripting vulnerability in chattermate.chat, published on 24 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

ChatterMate is a no-code AI chatbot agent framework. In versions 1.0.8 and below, the chatbot accepts and executes malicious HTML/JavaScript payloads when supplied as chat input. Specifically, an <iframe> payload containing a javascript: URI can be processed and executed in the browser context. This allows access to sensitive client-side data such as localStorage tokens and cookies, resulting in client-side injection. This issue has been fixed in version 1.0.9.

Weakness: CWE-79

Which versions are affected by CVE-2026-24399?

It affects 1 product.

Products include Chattermate Chattermate.

How do I fix CVE-2026-24399?

No fix has been published for CVE-2026-24399 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-24399 being exploited?

There is no known exploitation of CVE-2026-24399 in the wild and no public exploit code.

Sources

Also known as GHSA-72p3-w95w-q3j4.

Is CVE-2026-24399 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free