# CVE-2026-24399: ChatterMate has Stored Cross-Site Scripting (XSS) via Chatbot Input Execution

> Attackers can execute malicious scripts via chat input to steal sensitive client-side data like tokens and cookies.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Jan 2026
- **Updated:** 26 Jan 2026
- **Also known as:** GHSA-72p3-w95w-q3j4

## What is CVE-2026-24399?

CVE-2026-24399 is a critical cross-site scripting vulnerability in chattermate.chat, published on 24 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ChatterMate is a no-code AI chatbot agent framework. In versions 1.0.8 and below, the chatbot accepts and executes malicious HTML/JavaScript payloads when supplied as chat input. Specifically, an <iframe> payload containing a javascript: URI can be processed and executed in the browser context. This allows access to sensitive client-side data such as localStorage tokens and cookies, resulting in client-side injection. This issue has been fixed in version 1.0.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-24399?

It affects 1 product.


Products: Chattermate Chattermate.

## How do I fix CVE-2026-24399?

No fix has been published for CVE-2026-24399 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-24399 being exploited?

There is no known exploitation of CVE-2026-24399 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24399 and fix it if it is affected.

What it is: CVE-2026-24399 is a critical cross-site scripting vulnerability in chattermate.chat, published on 24 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-24399 in the wild and no public exploit code.

Affected product: chattermate.chat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24399/ (Markdown: https://insights.sbomify.com/CVE-2026-24399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24399
- OSV: https://osv.dev/vulnerability/CVE-2026-24399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24399/
Summaries are generated and may contain mistakes; the official description above is the record.
