# CVE-2026-24415: OpenSTAManager affected by reflected XSS in modifica_iva.php via righe parameter

> Attackers can inject arbitrary JavaScript via the righe parameter in OpenSTAManager, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 4 Mar 2026
- **Also known as:** GHSA-jfgp-g7x7-j25j

## What is CVE-2026-24415?

CVE-2026-24415 is a medium-severity cross-site scripting vulnerability in devcode-it openstamanager, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenSTAManager is an open source management software for technical assistance and invoicing. OpenSTAManager v2.9.8 and earlier contains Reflected XSS vulnerabilities in invoice/order/contract modification modals. The application fails to properly sanitize user-supplied input from the righe GET parameter before reflecting it in HTML output.The $_GET['righe'] parameter is directly echoed into the HTML value attribute without any sanitization using htmlspecialchars() or equivalent functions. This allows an attacker to break out of the attribute context and inject arbitrary HTML/JavaScript.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-24415?

2 open source packages ship an affected version, including devcode-it/openstamanager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devcode-it/openstamanager` | Packagist | All versions | 2.9.8 |
| `devcode-it/openstamanager` | Packagist | All versions | 2.9.8 |

Products: Devcode Openstamanager.

## How do I fix CVE-2026-24415?

Upgrade devcode-it/openstamanager to 2.9.8 or later.

## Is CVE-2026-24415 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24415 exists.

Public exploit code:

- CVE-2026-24415 - OpenSTAManager Affected by XSS in modifica_iva.php via righe parameter (github_poc): https://github.com/lukasz-rybak/CVE-2026-24415

## Other vulnerabilities in devcode-it openstamanager

- [CVE-2026-27012](https://insights.sbomify.com/CVE-2026-27012/): Unauthenticated privilege escalation in OpenSTAManager via modules/utenti/actions.php (critical 9.8)
- [CVE-2025-69212](https://insights.sbomify.com/CVE-2025-69212/): OpenSTAManager has an OS Command Injection in P7M File Processing (critical 9.4)
- [CVE-2026-35470](https://insights.sbomify.com/CVE-2026-35470/): OpenSTAManager has a SQL Injection via righe Parameter in confronta_righe Modals (high 8.8)
- [CVE-2026-28805](https://insights.sbomify.com/CVE-2026-28805/): OpenSTAManager: Time-Based Blind SQL Injection via `options[stato]` Parameter (high 8.8)
- [CVE-2026-35168](https://insights.sbomify.com/CVE-2026-35168/): OpenSTAManager: SQL Injection via Aggiornamenti Module (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24415 and fix it if it is affected.

What it is: CVE-2026-24415 is a medium-severity cross-site scripting vulnerability in devcode-it openstamanager, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24415 exists.

Affected packages and fixed versions:
- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.9.8
- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24415/ (Markdown: https://insights.sbomify.com/CVE-2026-24415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24415
- OSV: https://osv.dev/vulnerability/CVE-2026-24415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24415/
Summaries are generated and may contain mistakes; the official description above is the record.
