CVE-2026-24421 phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user
Authenticated non-admin users can access the backup endpoint to retrieve configuration backups due to missing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24421?
CVE-2026-24421 is a medium-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.
Weakness: CWE-862
Which versions are affected by CVE-2026-24421?
4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | All versions | 4.0.17 |
phpmyfaq/phpmyfaq Packagist | All versions | 4.0.17 |
thorsten/phpmyfaq Packagist | All versions | 4.0.17 |
thorsten/phpmyfaq Packagist | All versions | 4.0.17 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2026-24421?
Upgrade phpmyfaq/phpmyfaq to 4.0.17 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-24421 being exploited?
There is no known exploitation of CVE-2026-24421 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-wm8h-26fv-mg7g.