{"answers":{"affected":"4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24421 in the wild and no public exploit code.","fix":"Upgrade phpmyfaq/phpmyfaq to 4.0.17 or later.","what":"CVE-2026-24421 is a medium-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24421 and fix it if it is affected.\n\nWhat it is: CVE-2026-24421 is a medium-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24421/ (Markdown: https://insights.sbomify.com/CVE-2026-24421/index.md)","id":"CVE-2026-24421","markdown":"https://insights.sbomify.com/CVE-2026-24421/index.md","name":"CVE-2026-24421","record":{"aliases":["GHSA-wm8h-26fv-mg7g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ web application","requires_auth":"low_privilege","summary":"Authenticated non-admin users can access the backup endpoint to retrieve configuration backups due to missing authorization checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2026-04-29","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-04-29","kind":"exploitdb","ref":"52523","stars":null,"title":"phpMyFAQ  4.0.16 - Improper Authorization"}],"tier":"poc_unverified"},"has_fix":true,"headline":"phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user","id":"CVE-2026-24421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"phpMyFAQ: Public API endpoints expose emails and invisible questions","id":"CVE-2026-24422"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-wm8h-26fv-mg7g"},{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-wm8h-26fv-mg7g"},{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-wm8h-26fv-mg7g"},{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-wm8h-26fv-mg7g"}],"prev":{"headline":"phpMyFAQ: Attachment download allowed without dlattachment right (broken access control)","id":"CVE-2026-24420"},"products":["phpMyFAQ"],"published":"2026-01-24","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-26","vendors":["thorsten"]},"summary":"Authenticated non-admin users can access the backup endpoint to retrieve configuration backups due to missing authorization checks.","url":"https://insights.sbomify.com/CVE-2026-24421/"}