# CVE-2026-24421: phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user

> Authenticated non-admin users can access the backup endpoint to retrieve configuration backups due to missing authorization checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2026
- **Updated:** 26 Jan 2026
- **Also known as:** GHSA-wm8h-26fv-mg7g

## What is CVE-2026-24421?

CVE-2026-24421 is a medium-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-24421?

4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.0.17 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.0.17 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.17 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.17 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2026-24421?

Upgrade phpmyfaq/phpmyfaq to 4.0.17 or later.

## Is CVE-2026-24421 being exploited?

There is no known exploitation of CVE-2026-24421 in the wild and no public exploit code.

Public exploit code:

- phpMyFAQ  4.0.16 - Improper Authorization (exploitdb)

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24421 and fix it if it is affected.

What it is: CVE-2026-24421 is a medium-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24421 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24421/ (Markdown: https://insights.sbomify.com/CVE-2026-24421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24421
- OSV: https://osv.dev/vulnerability/CVE-2026-24421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24421/
Summaries are generated and may contain mistakes; the official description above is the record.
