{"answers":{"affected":"4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24422 exists.","fix":"Upgrade phpmyfaq/phpmyfaq to 4.0.17 or later.","what":"CVE-2026-24422 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24422 and fix it if it is affected.\n\nWhat it is: CVE-2026-24422 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 24 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24422 exists.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24422/ (Markdown: https://insights.sbomify.com/CVE-2026-24422/index.md)","id":"CVE-2026-24422","markdown":"https://insights.sbomify.com/CVE-2026-24422/index.md","name":"CVE-2026-24422","record":{"aliases":["GHSA-j4rc-96xj-gvqc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ web application","requires_auth":"none","summary":"Attackers can access private FAQ content and user email addresses via public API endpoints due to insufficient access controls.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"phpMyFAQ is an open source FAQ web application. In versions 4.0.16 and below, multiple public API endpoints improperly expose sensitive user information due to insufficient access controls. The OpenQuestionController::list() endpoint calls Question::getAll() with showAll=true by default, returning records marked as non-public (isVisible=false) along with user email addresses, with similar exposures present in comment, news, and FAQ APIs. This information disclosure vulnerability could enable attackers to harvest email addresses for phishing campaigns or access content that was explicitly marked as private. This issue has been fixed in version 4.0.17.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ: Public API endpoints expose emails and invisible questions","id":"CVE-2026-24422","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"information_disclosure","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"SmarterTools SmarterMail Missing Authentication for Critical Function","id":"CVE-2026-24423"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-j4rc-96xj-gvqc"},{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-j4rc-96xj-gvqc"},{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-j4rc-96xj-gvqc"},{"ecosystem":"Packagist","fixed":["4.0.17"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-j4rc-96xj-gvqc"}],"prev":{"headline":"phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user","id":"CVE-2026-24421"},"products":["phpMyFAQ"],"published":"2026-01-24","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-26","vendors":["thorsten"]},"summary":"Attackers can access private FAQ content and user email addresses via public API endpoints due to insufficient access controls.","url":"https://insights.sbomify.com/CVE-2026-24422/"}