# CVE-2026-24425: Twig 2.16.x & 3.9.0-3.25.x Sandbox Bypass via SourcePolicyInterface

> Attackers with template rendering capabilities can bypass Twig sandbox restrictions to execute arbitrary code when using specific source policies.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-24425, GHSA-2q52-x2ff-qgfr, ROOT-APP-COMPOSER-CVE-2026-24425, UBUNTU-CVE-2026-24425, USN-8408-1

## What is CVE-2026-24425?

CVE-2026-24425 is a high-severity vulnerability in twigphp Twig, published on 20 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Twig versions 2.16.x and 3.9.0 through 3.25.x contain a sandbox bypass vulnerability when using a SourcePolicyInterface that allows attackers with template rendering capabilities to pass arbitrary PHP callables to sort, filter, map, and reduce filters. Attackers can exploit the runtime check that fails to use the current template source to bypass sandbox restrictions and execute arbitrary code when the sandbox is enabled through a source policy rather than globally.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-24425?

4 open source packages ship an affected version, including twig/twig. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twig/twig` | Packagist | From 2.16.0 to 2.16.1 | None |
| `twig/twig` | Packagist | From 2.16.0 to 2.16.1 | None |
| `twig/twig` | Packagist | From 3.9.0 | 3.26.0 |
| `twig/twig` | Packagist | From 3.9.0 | 3.26.0 |

Products: Symfony Twig.

## How do I fix CVE-2026-24425?

Upgrade twig/twig to 3.26.0 or later.

## Is CVE-2026-24425 being exploited?

There is no known exploitation of CVE-2026-24425 in the wild and no public exploit code.

## Other vulnerabilities in twigphp Twig

- [CVE-2018-13818](https://insights.sbomify.com/CVE-2018-13818/): Code injection in n/a (critical 9.8)
- [CVE-2026-46633](https://insights.sbomify.com/CVE-2026-46633/): Twig: PHP code injection via `{% use %}` template name (high 8.7)
- [CVE-2026-46640](https://insights.sbomify.com/CVE-2026-46640/): Twig: Arbitrary PHP code execution via `_self.(<string>)` macro-reference compilation (high 8.7)
- [CVE-2024-45411](https://insights.sbomify.com/CVE-2024-45411/): Twig has a possible sandbox bypass (high 8.6)
- [CVE-2026-46634](https://insights.sbomify.com/CVE-2026-46634/): Twig: `template_from_string()` escapes a SourcePolicy-driven sandbox via synthesized template name (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24425 and fix it if it is affected.

What it is: CVE-2026-24425 is a high-severity vulnerability in twigphp Twig, published on 20 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24425 in the wild and no public exploit code.

Affected packages and fixed versions:
- twig/twig (Packagist): affected from 2.16.0 up to 2.16.1; no fix listed
- twig/twig (Packagist): affected from 2.16.0 up to 2.16.1; no fix listed
- twig/twig (Packagist): affected from 3.9.0; fixed in 3.26.0
- twig/twig (Packagist): affected from 3.9.0; fixed in 3.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24425/ (Markdown: https://insights.sbomify.com/CVE-2026-24425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24425
- OSV: https://osv.dev/vulnerability/CVE-2026-24425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24425/
Summaries are generated and may contain mistakes; the official description above is the record.
