CVE-2026-24458 DoS attack via login attempts with multi-megabyte passwords
Attackers can cause server CPU and memory exhaustion by submitting login attempts with multi-megabyte passwords, requiring administrators to upgrade Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24458?
CVE-2026-24458 is a high-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly handle very long passwords, which allows an attacker to overload the server CPU and memory via executing login attempts with multi-megabyte passwords. Mattermost Advisory ID: MMSA-2026-00587
Weakness: CWE-770
Which versions are affected by CVE-2026-24458?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260129164748-7201f42d955f |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260129164748-7201f42d955f |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.3 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260129164748-7201f42d955f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260129164748-7201f42d955f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260129164748-7201f42d955f |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-24458?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260129164748-7201f42d955f, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-24458 being exploited?
There is no known exploitation of CVE-2026-24458 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-m5rv-56xx-hfc6, GO-2026-4731.