# CVE-2026-24486: Python-Multipart has Arbitrary File Write via Non-Default Configuration

> Attackers can write files to arbitrary filesystem locations via crafted filenames when specific non-default upload options are enabled.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 16 Sep 2026
- **Also known as:** CLSA-2026-1786503821, DEBIAN-CVE-2026-24486, GHSA-wp53-j4wj-2cfg, MINI-22c2-9f9f-8w32, MINI-4v6r-gr5c-j43v, MINI-5fm2-57p5-xhq9, MINI-wxr3-frx2-fjgg, MINI-xf3r-mp87-c926, OESA-2026-2276, PYSEC-2026-1852, ROOT-APP-PYPI-CVE-2026-24486, SUSE-SU-2026:0307-1, SUSE-SU-2026:20188-1, UBUNTU-CVE-2026-24486, openSUSE-SU-2026:20125-1

## What is CVE-2026-24486?

CVE-2026-24486 is a high-severity path traversal vulnerability in Kludex python-multipart, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python-Multipart is a streaming multipart parser for Python. Prior to version 0.0.22, a Path Traversal vulnerability exists when using non-default configuration options `UPLOAD_DIR` and `UPLOAD_KEEP_FILENAME=True`. An attacker can write uploaded files to arbitrary locations on the filesystem by crafting a malicious filename. Users should upgrade to version 0.0.22 to receive a patch or, as a workaround, avoid using `UPLOAD_KEEP_FILENAME=True` in project configurations.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-24486?

3 open source packages ship an affected version, including python-multipart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-multipart` | PyPI | All versions | 0.0.22 |
| `python-multipart` | PyPI | All versions | 0.0.22 |
| `python-multipart` | PyPI | All versions | 0.0.22 |
| `python-python-multipart` | SUSE:Linux Enterprise Server 16.0 | All versions | 0.0.20-160000.3.1 |
| `python-python-multipart` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 0.0.20-160000.3.1 |
| `python-python-multipart` | openSUSE:Leap 15.6 | All versions | 0.0.9-150600.3.6.1 |
| `python-python-multipart` | openSUSE:Leap 16.0 | All versions | 0.0.20-160000.3.1 |

Products: Fastapiexpert Python-Multipart.

## How do I fix CVE-2026-24486?

Upgrade python-multipart to 0.0.22 or later.

## Is CVE-2026-24486 being exploited?

There is no known exploitation of CVE-2026-24486 in the wild and no public exploit code.

Public exploit code:

- Python-Multipart 0.0.22 - Path Traversal (exploitdb)

## Other vulnerabilities in Kludex python-multipart

- [CVE-2026-53539](https://insights.sbomify.com/CVE-2026-53539/): Python-Multipart: Quadratic-time querystring parsing with semicolon separators causes CPU denial of service (high 7.5)
- [CVE-2024-24762](https://insights.sbomify.com/CVE-2024-24762/): python-multipart vulnerable to content-type header Regular expression Denial of Service (high 7.5)
- [CVE-2026-40347](https://insights.sbomify.com/CVE-2026-40347/): Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data (medium 5.3)
- [CVE-2026-53537](https://insights.sbomify.com/CVE-2026-53537/): Python-Multipart: Content-Disposition parameter smuggling via RFC 2231/5987 extended parameters (low 3.7)
- [CVE-2026-53538](https://insights.sbomify.com/CVE-2026-53538/): Python-Multipart: Semicolon treated as querystring field separator enables parameter smuggling (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24486 and fix it if it is affected.

What it is: CVE-2026-24486 is a high-severity path traversal vulnerability in Kludex python-multipart, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24486 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-multipart (PyPI): affected all versions; fixed in 0.0.22
- python-multipart (PyPI): affected all versions; fixed in 0.0.22
- python-multipart (PyPI): affected all versions; fixed in 0.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24486/ (Markdown: https://insights.sbomify.com/CVE-2026-24486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24486
- OSV: https://osv.dev/vulnerability/CVE-2026-24486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24486/
Summaries are generated and may contain mistakes; the official description above is the record.
