# CVE-2026-24490: MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field

> Attacker can execute arbitrary JavaScript in victim's browser via malicious APK upload, leading to session hijacking and account takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-8hf7-h89p-3pqj, PYSEC-2026-1668

## What is CVE-2026-24490?

CVE-2026-24490 is a high-severity cross-site scripting vulnerability in Mobile-Security-Framework-MobSF, published on 27 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

MobSF is a mobile application security testing tool used. Prior to version 4.4.5, a Stored Cross-site Scripting (XSS) vulnerability in MobSF's Android manifest analysis allows an attacker to execute arbitrary JavaScript in the context of a victim's browser session by uploading a malicious APK. The `android:host` attribute from `<data android:scheme="android_secret_code">` elements is rendered in HTML reports without sanitization, enabling session hijacking and account takeover. Version 4.4.5 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-24490?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 4.4.5 |
| `mobsf` | PyPI | All versions | 4.4.5 |
| `mobsf` | PyPI | All versions | 4.4.5 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2026-24490?

Upgrade mobsf to 4.4.5 or later.

## Is CVE-2026-24490 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24490 exists.

## Other vulnerabilities in Mobile-Security-Framework-MobSF

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)
- [CVE-2024-43399](https://insights.sbomify.com/CVE-2024-43399/): Mobile Security Framework (MobSF) has a Zip Slip Vulnerability in .a Static Library Files (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24490 and fix it if it is affected.

What it is: CVE-2026-24490 is a high-severity cross-site scripting vulnerability in Mobile-Security-Framework-MobSF, published on 27 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24490 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 4.4.5
- mobsf (PyPI): affected all versions; fixed in 4.4.5
- mobsf (PyPI): affected all versions; fixed in 4.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24490/ (Markdown: https://insights.sbomify.com/CVE-2026-24490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24490
- OSV: https://osv.dev/vulnerability/CVE-2026-24490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24490/
Summaries are generated and may contain mistakes; the official description above is the record.
