# CVE-2026-2455: SSRF bypass via IPv4-mapped IPv6 literals

> Attackers can bypass SSRF protections using IPv4-mapped IPv6 literals to access internal services in Mattermost.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-gqv7-j2j8-qmwq, GO-2026-4746

## What is CVE-2026-2455?

CVE-2026-2455 is a medium-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to canonicalize IPv4-mapped IPv6 addresses before reserved IP validation which allows an attacker to perform SSRF attacks against internal services via IPv4-mapped IPv6 literals (e.g., [::ffff:127.0.0.1]).. Mattermost Advisory ID: MMSA-2026-00585

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-2455?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20260129133647-5d787969c2d5 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20260129133647-5d787969c2d5 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1 | 10.11.11 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1 | 10.11.11 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1+incompatible | 10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0-rc1 | 11.2.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0-rc1 | 11.2.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.3.0-rc1 | 11.3.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.3.0-rc1 | 11.3.1 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260129133647-5d787969c2d5 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260129133647-5d787969c2d5 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260129133647-5d787969c2d5 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-2455?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260129133647-5d787969c2d5, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.

## Is CVE-2026-2455 being exploited?

There is no known exploitation of CVE-2026-2455 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2455 and fix it if it is affected.

What it is: CVE-2026-2455 is a medium-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2455 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20260129133647-5d787969c2d5
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20260129133647-5d787969c2d5
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1; fixed in 10.11.11
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1; fixed in 10.11.11
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1+incompatible; fixed in 10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0-rc1; fixed in 11.2.3
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0-rc1; fixed in 11.2.3
- github.com/mattermost/mattermost-server (Go): affected from 11.3.0-rc1; fixed in 11.3.1
- github.com/mattermost/mattermost-server (Go): affected from 11.3.0-rc1; fixed in 11.3.1
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260129133647-5d787969c2d5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2455/ (Markdown: https://insights.sbomify.com/CVE-2026-2455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2455
- OSV: https://osv.dev/vulnerability/CVE-2026-2455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2455/
Summaries are generated and may contain mistakes; the official description above is the record.
