CVE-2026-2456 Denial of Service via Unbounded Memory Allocation in Integration Actions

Medium 5.3 Published Updated

An authenticated attacker can cause server memory exhaustion and denial of service by configuring a malicious integration server to return large responses.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-2456?

CVE-2026-2456 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 Mattermost fails to limit the size of responses from integration action endpoints, which allows an authenticated attacker to cause server memory exhaustion and denial of service via a malicious integration server that returns an arbitrarily large response when a user clicks an interactive message button.. Mattermost Advisory ID: MMSA-2026-00571

Weakness: CWE-789

Which versions are affected by CVE-2026-2456?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260127165411-fe3052073dc6
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260127165411-fe3052073dc6
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc110.11.11
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc110.11.11
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc1+incompatible10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible
github.com/mattermost/mattermost-server GoFrom 11.2.0-rc111.2.3
8 more packages
github.com/mattermost/mattermost-server GoFrom 11.2.0-rc111.2.3
github.com/mattermost/mattermost-server GoFrom 11.3.0-rc111.3.1
github.com/mattermost/mattermost-server GoFrom 11.3.0-rc111.3.1
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260127165411-fe3052073dc6
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260127165411-fe3052073dc6
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260127165411-fe3052073dc6

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-2456?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260127165411-fe3052073dc6, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-2456 being exploited?

There is no known exploitation of CVE-2026-2456 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-34g8-9fpp-46ch, GO-2026-4726.

Is CVE-2026-2456 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free