CVE-2026-2457 WebSocket Message Spoofing via Permalink Embed Manipulation

Medium 4.3 Published Updated

Authenticated attackers can spoof permalink embeds to impersonate other users by manipulating post metadata in Mattermost.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-2457?

CVE-2026-2457 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to sanitize client-supplied post metadata which allows an authenticated attacker to spoof permalink embeds impersonating other users via crafted PUT requests to the post update API endpoint.. Mattermost Advisory ID: MMSA-2025-00569

Weakness: CWE-346

Which versions are affected by CVE-2026-2457?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260123211116-9efe617be8b8
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260123211116-9efe617be8b8
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc110.11.11
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc110.11.11
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc1+incompatible10.11.11+incompatible, 11.2.3+incompatible, 11.3.1+incompatible
github.com/mattermost/mattermost-server GoFrom 11.2.0-rc111.2.3
8 more packages
github.com/mattermost/mattermost-server GoFrom 11.2.0-rc111.2.3
github.com/mattermost/mattermost-server GoFrom 11.3.0-rc111.3.1
github.com/mattermost/mattermost-server GoFrom 11.3.0-rc111.3.1
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260123211116-9efe617be8b8
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260123211116-9efe617be8b8
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260123211116-9efe617be8b8

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-2457?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20260123211116-9efe617be8b8, 10.11.11, 10.11.11+incompatible or 11.2.3+incompatible.

Is CVE-2026-2457 being exploited?

There is no known exploitation of CVE-2026-2457 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-ph22-fw5m-w2q9, GO-2026-4732.

Is CVE-2026-2457 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free