# CVE-2026-2461: Missing authorization check allows unauthorized modification of other users' comments on a board

> An attacker with editor permissions can modify comments created by other users due to missing authorization checks in Mattermost plugins.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-hf8w-x9h5-5gf9, GO-2026-4782

## What is CVE-2026-2461?

CVE-2026-2461 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost Plugins versions <=11.3 11.0.3 11.2.2 10.10.11.0 fail to implement authorisation checks on comment block modifications, which allows an authorised attacker with editor permission to modify comments created by other board members.  Mattermost Advisory ID: MMSA-2025-00559

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-2461?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-boards. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-boards` | Go | All versions | 0.0.0-20260108044135-57c5be5b6ef5 |
| `github.com/mattermost/mattermost-plugin-boards` | Go | All versions | 0.0.0-20260108044135-57c5be5b6ef5 |
| `github.com/mattermost/mattermost-plugin-boards` | Go | All versions | 0.0.0-20260108044135-57c5be5b6ef5 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-2461?

Upgrade github.com/mattermost/mattermost-plugin-boards to 0.0.0-20260108044135-57c5be5b6ef5 or later.

## Is CVE-2026-2461 being exploited?

There is no known exploitation of CVE-2026-2461 in the wild and no public exploit code.

Public exploit code:

- POC in python for CVE-2026-2461 (github_poc): https://github.com/destiny-creates/CVE-2026-2461-poc

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2461 and fix it if it is affected.

What it is: CVE-2026-2461 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2461 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-boards (Go): affected all versions; fixed in 0.0.0-20260108044135-57c5be5b6ef5
- github.com/mattermost/mattermost-plugin-boards (Go): affected all versions; fixed in 0.0.0-20260108044135-57c5be5b6ef5
- github.com/mattermost/mattermost-plugin-boards (Go): affected all versions; fixed in 0.0.0-20260108044135-57c5be5b6ef5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2461/ (Markdown: https://insights.sbomify.com/CVE-2026-2461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2461
- OSV: https://osv.dev/vulnerability/CVE-2026-2461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2461/
Summaries are generated and may contain mistakes; the official description above is the record.
