# CVE-2026-24661: Unbounded Request Body Read in MS Teams Plugin {{/changes}} Webhook Endpoint

> An authenticated attacker can cause memory exhaustion and denial of service by sending oversized JSON payloads to the Mattermost Teams plugin webhook endpoint.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-5rfv-h47g-xj42, GO-2026-5153

## What is CVE-2026-24661?

CVE-2026-24661 is a low-severity denial of service vulnerability in Mattermost Mattermost, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mattermost Plugins versions <=2.1.3.0 fail to limit the request body size on the {{/changes}} webhook endpoint which allows an authenticated attacker to cause memory exhaustion and denial of service via sending an oversized JSON payload. Mattermost Advisory ID: MMSA-2026-00611

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-24661?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-msteams. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 1.15.1-0.20260213190728-6fe4d295592e |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 1.15.1-0.20260213190728-6fe4d295592e |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 1.15.1-0.20260213190728-6fe4d295592e |

Products: Mattermost Mattermost.

## How do I fix CVE-2026-24661?

Upgrade github.com/mattermost/mattermost-plugin-msteams to 1.15.1-0.20260213190728-6fe4d295592e or later.

## Is CVE-2026-24661 being exploited?

There is no known exploitation of CVE-2026-24661 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost

- [CVE-2019-20851](https://insights.sbomify.com/CVE-2019-20851/): Path traversal in n/a (critical 9.1)
- [CVE-2024-39274](https://insights.sbomify.com/CVE-2024-39274/): Malicious remote can add users to arbitrary teams and channels (high 8.7)
- [CVE-2024-39777](https://insights.sbomify.com/CVE-2024-39777/): Malicious remote can invite itself to an arbitrary local channel (high 8.7)
- [CVE-2024-39830](https://insights.sbomify.com/CVE-2024-39830/): Timing attack during remote cluster token comparison when shared channels are enabled (high 8.1)
- [CVE-2023-3615](https://insights.sbomify.com/CVE-2023-3615/): Lack of server certificate validation in websockets connection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24661 and fix it if it is affected.

What it is: CVE-2026-24661 is a low-severity denial of service vulnerability in Mattermost Mattermost, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24661 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 1.15.1-0.20260213190728-6fe4d295592e
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 1.15.1-0.20260213190728-6fe4d295592e
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 1.15.1-0.20260213190728-6fe4d295592e

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24661/ (Markdown: https://insights.sbomify.com/CVE-2026-24661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24661
- OSV: https://osv.dev/vulnerability/CVE-2026-24661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24661/
Summaries are generated and may contain mistakes; the official description above is the record.
