# CVE-2026-24677: FreeRDP has a heap-buffer-overflow in ecam_encoder_compress_h264

> An attacker can trigger a heap-buffer-overflow in FreeRDP's H.264 encoder by providing malicious server-controlled dimensions, potentially leading to code execution or crashes.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-24677, GHSA-xw37-j744-f8v7, MINI-hmgq-r9cm-27cw, UBUNTU-CVE-2026-24677

## What is CVE-2026-24677?

CVE-2026-24677 is a high-severity memory corruption vulnerability in Freerdp Freerdp, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FreeRDP is a free implementation of the Remote Desktop Protocol. Prior to 3.22.0, ecam_encoder_compress_h264 trusts server-controlled dimensions and does not validate the source buffer size, leading to an out-of-bounds read in sws_scale. This vulnerability is fixed in 3.22.0.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-24677?

It affects 1 product.


Products: Freerdp Freerdp.

## How do I fix CVE-2026-24677?

Upgrade to a fixed version.

## Is CVE-2026-24677 being exploited?

There is no known exploitation of CVE-2026-24677 in the wild and no public exploit code.

## Other vulnerabilities in Freerdp Freerdp

- [CVE-2021-37594](https://insights.sbomify.com/CVE-2021-37594/): Other in n/a (critical 9.8)
- [CVE-2021-37595](https://insights.sbomify.com/CVE-2021-37595/): Other in n/a (critical 9.8)
- [CVE-2026-67305](https://insights.sbomify.com/CVE-2026-67305/): FreeRDP Windows Client before 3.29.0 Heap Buffer Overflow via Cliprdr (critical 9.4)
- [CVE-2026-66402](https://insights.sbomify.com/CVE-2026-66402/): FreeRDP before 3.29.0 TLS Certificate Identity Validation Bypass (critical 9.3)
- [CVE-2026-67289](https://insights.sbomify.com/CVE-2026-67289/): FreeRDP before 3.29.0 HTTP Proxy Request Injection via Redirection (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24677 and fix it if it is affected.

What it is: CVE-2026-24677 is a high-severity memory corruption vulnerability in Freerdp Freerdp, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24677 in the wild and no public exploit code.

Affected product: Freerdp Freerdp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24677/ (Markdown: https://insights.sbomify.com/CVE-2026-24677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24677
- OSV: https://osv.dev/vulnerability/CVE-2026-24677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24677/
Summaries are generated and may contain mistakes; the official description above is the record.
