# CVE-2026-24688: pypdf has possible Infinite Loop when processing outlines/bookmarks

> An attacker can cause a denial of service via an infinite loop in pypdf by crafting a malicious PDF with specific outlines or bookmarks.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-24688, GHSA-2q4j-m29v-hq73, PYSEC-2026-1827, ROOT-APP-PYPI-CVE-2026-24688, UBUNTU-CVE-2026-24688, openSUSE-SU-2026:10116-1

## What is CVE-2026-24688?

CVE-2026-24688 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 27 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pypdf is a free and open-source pure-python PDF library. An attacker who uses an infinite loop vulnerability that is present in versions prior to 6.6.2 can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks. This has been fixed in pypdf 6.6.2. If projects cannot upgrade yet, consider applying the changes from PR #3610 manually.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-24688?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.6.2 |
| `pypdf` | PyPI | All versions | 6.6.2 |
| `pypdf` | PyPI | All versions | 6.6.2 |
| `python-pypdf` | openSUSE:Tumbleweed | All versions | 6.6.2-1.1 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-24688?

Upgrade pypdf to 6.6.2 or later.

## Is CVE-2026-24688 being exploited?

There is no known exploitation of CVE-2026-24688 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-24688 - pypdf - DoS - POC  (github_poc): https://github.com/JoakimBulow/CVE-2026-24688
- POC for CVE-2026-24688 (github_poc): https://github.com/Fomovet/cve-2026-24688

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24688 and fix it if it is affected.

What it is: CVE-2026-24688 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 27 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24688 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.6.2
- pypdf (PyPI): affected all versions; fixed in 6.6.2
- pypdf (PyPI): affected all versions; fixed in 6.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24688/ (Markdown: https://insights.sbomify.com/CVE-2026-24688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24688
- OSV: https://osv.dev/vulnerability/CVE-2026-24688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24688/
Summaries are generated and may contain mistakes; the official description above is the record.
