{"answers":{"affected":"2 open source packages ship an affected version, including directorytree/imapengine.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2469 exists.","fix":"Upgrade directorytree/imapengine to 1.22.3 or later.","what":"CVE-2026-2469 is a high-severity command injection vulnerability in directorytree/imapengine, published on 14 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-2469 and fix it if it is affected.\n\nWhat it is: CVE-2026-2469 is a high-severity command injection vulnerability in directorytree/imapengine, published on 14 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2469 exists.\n\nAffected packages and fixed versions:\n- directorytree/imapengine (Packagist): affected all versions; fixed in 1.22.3\n- directorytree/imapengine (Packagist): affected all versions; fixed in 1.22.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-2469/ (Markdown: https://insights.sbomify.com/CVE-2026-2469/index.md)","id":"CVE-2026-2469","markdown":"https://insights.sbomify.com/CVE-2026-2469/index.md","name":"CVE-2026-2469","record":{"aliases":["GHSA-rfq9-4wcm-64gh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP IMAP library","requires_auth":"low_privilege","summary":"Attackers can inject IMAP commands to read, delete emails, or terminate sessions by exploiting improper input escaping in the library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Versions of the package directorytree/imapengine before 1.22.3 are vulnerable to Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') via the id() function in ImapConnection.php due to improperly escaping user input before including it in IMAP ID commands. This allows attackers to read or delete victim's emails, terminate the victim's session or execute any valid IMAP command on victim's mailbox by including quote characters \" or CRLF sequences \\r\\n in the input.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ImapEngine affected by command injection via the ID command parameters","id":"CVE-2026-2469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Pagelayer \u003c= 2.0.9 - Incorrect Authorization to Authenticated (Contributor+) Mail Relay Configuration via 'contacts'","id":"CVE-2026-2470"},"packages":[{"ecosystem":"Packagist","fixed":["1.22.3"],"introduced":["0"],"last_affected":[],"package":"directorytree/imapengine","purl":null,"source":"GHSA-rfq9-4wcm-64gh"},{"ecosystem":"Packagist","fixed":["1.22.3"],"introduced":["0"],"last_affected":[],"package":"directorytree/imapengine","purl":"pkg:composer/directorytree/imapengine","source":"GHSA-rfq9-4wcm-64gh"}],"prev":{"headline":"Quentn WP \u003c= 1.2.12 - Unauthenticated SQL Injection via 'qntn_wp_access' Cookie","id":"CVE-2026-2468"},"products":["directorytree/imapengine"],"published":"2026-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-24","vendors":["n/a"]},"summary":"Attackers can inject IMAP commands to read, delete emails, or terminate sessions by exploiting improper input escaping in the library.","url":"https://insights.sbomify.com/CVE-2026-2469/"}