CVE-2026-24713 Apache IoTDB: JEXL Expression Injection Vulnerability

Critical 9.8 Published Updated

Attackers can execute arbitrary code via JEXL expression injection in Apache IoTDB, requiring an upgrade to secure the database.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-24713?

CVE-2026-24713 is a critical code injection vulnerability in Apache IoTDB, published on 9 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache IoTDB.

This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.

Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.

Weakness: CWE-917, CWE-20

Which versions are affected by CVE-2026-24713?

4 open source packages ship an affected version, including org.apache.iotdb:iotdb-core. It affects 1 product.

PackageAffectedFixed in
org.apache.iotdb:iotdb-core MavenFrom 1.0.01.3.7
org.apache.iotdb:iotdb-core MavenFrom 1.0.01.3.7
org.apache.iotdb:iotdb-core MavenFrom 2.0.02.0.7
org.apache.iotdb:iotdb-core MavenFrom 2.0.02.0.7

Products include Apache Iotdb.

How do I fix CVE-2026-24713?

Upgrade org.apache.iotdb:iotdb-core to a fixed version for your release line: 1.3.7 or 2.0.7.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-24713 being exploited?

There is no known exploitation of CVE-2026-24713 in the wild and no public exploit code.

Sources

Also known as GHSA-6w48-2g9j-v9q5.

Is CVE-2026-24713 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free