# CVE-2026-2472: Stored Cross-Site Scripting (XSS) in Vertex AI Python SDK Visualization

> An attacker can inject malicious JavaScript into Vertex AI SDK evaluation results, executing code in victim Jupyter or Colab environments.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ECHO-5a8a-19c3-eaef, GHSA-qv8j-hgpc-vrq8, MINI-4867-j8rc-34gm, MINI-f47q-c4x4-wvpq, PYSEC-2026-2499

## What is CVE-2026-2472?

CVE-2026-2472 is a high-severity cross-site scripting vulnerability in Google Cloud Vertex AI SDK for Python, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Stored Cross-Site Scripting (XSS) in the _genai/_evals_visualization component of Google Cloud Vertex AI SDK (google-cloud-aiplatform) versions from 1.98.0 up to (but not including) 1.131.0 allows an unauthenticated remote attacker to execute arbitrary JavaScript in a victim's Jupyter or Colab environment via injecting script escape sequences into model evaluation results or dataset JSON data.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-2472?

3 open source packages ship an affected version, including google-cloud-aiplatform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `google-cloud-aiplatform` | PyPI | From 1.98.0 | 1.131.0 |
| `google-cloud-aiplatform` | PyPI | From 1.98.0 | 1.131.0 |
| `google-cloud-aiplatform` | PyPI | From 1.98.0 | 1.131.0 |

## How do I fix CVE-2026-2472?

Upgrade google-cloud-aiplatform to 1.131.0 or later.

## Is CVE-2026-2472 being exploited?

There is no known exploitation of CVE-2026-2472 in the wild and no public exploit code.

Public exploit code:

- Technical PoC for CVE-2026-2472 (GCP-2026-011): Unauthenticated and Stored Cross-Site Scripting (XSS) in google-cloud-aiplatform _genai/_evals_visualization (Vertex AI Python SDK) affecting Jupyter/Colab. (github_poc): https://github.com/JoshuaProvoste/CVE-2026-2472-Vertex-AI-SDK-Google-Cloud
- Expose and detail an unauthenticated stored XSS vulnerability in the Google Cloud Vertex AI Python SDK affecting versions 1.98.0 to 1.130.9. (github_poc): https://github.com/megafart1/CVE-2026-2472-Vertex-AI-SDK-Google-Cloud

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2472 and fix it if it is affected.

What it is: CVE-2026-2472 is a high-severity cross-site scripting vulnerability in Google Cloud Vertex AI SDK for Python, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-2472 in the wild and no public exploit code.

Affected packages and fixed versions:
- google-cloud-aiplatform (PyPI): affected from 1.98.0; fixed in 1.131.0
- google-cloud-aiplatform (PyPI): affected from 1.98.0; fixed in 1.131.0
- google-cloud-aiplatform (PyPI): affected from 1.98.0; fixed in 1.131.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2472/ (Markdown: https://insights.sbomify.com/CVE-2026-2472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2472
- OSV: https://osv.dev/vulnerability/CVE-2026-2472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2472/
Summaries are generated and may contain mistakes; the official description above is the record.
