# CVE-2026-2473: Bucket Squatting in Vertex AI Experiments leads to RCE and Model Theft.

> Unauthenticated attackers can achieve remote code execution and model theft by pre-creating predictable Cloud Storage buckets in Vertex AI Experiments.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 23 Feb 2026
- **Also known as:** ECHO-1631-918e-c957, GHSA-wh2j-26j7-9728, MINI-2wx4-qm3x-w6h5, MINI-5hq6-jvqx-g877, MINI-74r4-hjh8-6jw4, PYSEC-2026-2500

## What is CVE-2026-2473?

CVE-2026-2473 is a high-severity vulnerability in Google Cloud Vertex AI Experiments, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Predictable bucket naming in Vertex AI Experiments in Google Cloud Vertex AI from version 1.21.0 up to (but not including) 1.133.0 on Google Cloud Platform allows an unauthenticated remote attacker to achieve cross-tenant remote code execution, model theft, and poisoning via pre-creating predictably named Cloud Storage buckets (Bucket Squatting).

This vulnerability was patched and no customer action is needed.

Weakness: CWE-340 (Generation of Predictable Numbers or Identifiers)

## Which versions are affected by CVE-2026-2473?

3 open source packages ship an affected version, including google-cloud-aiplatform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `google-cloud-aiplatform` | PyPI | From 1.21.0 | 1.133.0 |
| `google-cloud-aiplatform` | PyPI | From 1.21.0 | 1.133.0 |
| `google-cloud-aiplatform` | PyPI | From 1.21.0 | 1.133.0 |

## How do I fix CVE-2026-2473?

Upgrade google-cloud-aiplatform to 1.133.0 or later.

## Is CVE-2026-2473 being exploited?

There is no known exploitation of CVE-2026-2473 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2473 and fix it if it is affected.

What it is: CVE-2026-2473 is a high-severity vulnerability in Google Cloud Vertex AI Experiments, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-2473 in the wild and no public exploit code.

Affected packages and fixed versions:
- google-cloud-aiplatform (PyPI): affected from 1.21.0; fixed in 1.133.0
- google-cloud-aiplatform (PyPI): affected from 1.21.0; fixed in 1.133.0
- google-cloud-aiplatform (PyPI): affected from 1.21.0; fixed in 1.133.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2473/ (Markdown: https://insights.sbomify.com/CVE-2026-2473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2473
- OSV: https://osv.dev/vulnerability/CVE-2026-2473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2473/
Summaries are generated and may contain mistakes; the official description above is the record.
