# CVE-2026-24733: Apache Tomcat: Security constraint bypass with HTTP/0.9


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Feb 2026
- **Updated:** 11 Mar 2026
- **Also known as:** BIT-tomcat-2026-24733, CLEANSTART-2026-PZ00337, CLSA-2026-1771978235, CLSA-2026-1772496672, CLSA-2026-1774859936, CLSA-2026-1775003158, CLSA-2026-1775608273, CLSA-2026-1775608278, CLSA-2026-1784077491, DEBIAN-CVE-2026-24733, GHSA-qq5r-98hh-rxc9, MINI-cwpg-jpm4-2c2j, MINI-hhqp-j78f-3qxp, MINI-jg6m-xmq9-hxh6, MINI-p23x-9c43-mh9h, MINI-q8wm-xf58-mj9v, MINI-wwvv-qv84-8gf7, SUSE-SU-2026:0922-1, UBUNTU-CVE-2026-24733

## What is CVE-2026-24733?

CVE-2026-24733 is a medium-severity vulnerability in Apache Tomcat, published on 17 Feb 2026. 

### Official description

Improper Input Validation vulnerability in Apache Tomcat.

Tomcat did not limit HTTP/0.9 requests to the GET method. If a security 
constraint was configured to allow HEAD requests to a URI but deny GET 
requests, the user could bypass that constraint on GET requests by 
sending a (specification invalid) HEAD request using HTTP/0.9.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112.

Older, EOL versions are also affected.

Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-24733?

7 open source packages ship an affected version, including org.apache.tomcat:tomcat-coyote and tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat-coyote` | Maven | All versions | 9.0.113 |
| `org.apache.tomcat:tomcat-coyote` | Maven | All versions | 9.0.113 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.50 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.50 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.15 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.15 |
| `tomcat` | Bitnami | All versions | 9.0.113, 10.1.50, 11.0.15 |
| `tomcat` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 9.0.36-3.156.1 |

Products: Apache Tomcat.

## How do I fix CVE-2026-24733?

Upgrade org.apache.tomcat:tomcat-coyote to a fixed version for your release line: 9.0.113, 10.1.50 or 11.0.15.

## Is CVE-2026-24733 being exploited?

There is no known exploitation of CVE-2026-24733 in the wild and no public exploit code.

Public exploit code:

- ## What is CVE-2026-24733?  Apache Tomcat incorrectly handled an HTTP/0.9-style `HEAD` request under certain security-constraint configurations. (github_poc): https://github.com/Darabium/CVE-2026-24733

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24733 and fix it if it is affected.

What it is: CVE-2026-24733 is a medium-severity vulnerability in Apache Tomcat, published on 17 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-24733 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat-coyote (Maven): affected all versions; fixed in 9.0.113
- org.apache.tomcat:tomcat-coyote (Maven): affected all versions; fixed in 9.0.113
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.0-M1; fixed in 10.1.50
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.0-M1; fixed in 10.1.50
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.0-M1; fixed in 11.0.15
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.0-M1; fixed in 11.0.15
- tomcat (Bitnami): affected all versions; fixed in 9.0.113, 10.1.50, 11.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24733/ (Markdown: https://insights.sbomify.com/CVE-2026-24733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24733
- OSV: https://osv.dev/vulnerability/CVE-2026-24733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24733/
Summaries are generated and may contain mistakes; the official description above is the record.
