CVE-2026-24735 Apache Answer: Revision API Improper Access Control leads to Information Disclosure

High 7.5 Published Updated

Unauthenticated users can access full revision history of deleted content, exposing sensitive information in Apache Answer.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-24735?

CVE-2026-24735 is a high-severity missing authorization vulnerability in Apache Answer, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of Private Personal Information to an Unauthorized Actor vulnerability in Apache Answer.

This issue affects Apache Answer: through 1.7.1.

An unauthenticated API endpoint incorrectly exposes full revision history for deleted content. This allows unauthorized user to retrieve restricted or sensitive information. Users are recommended to upgrade to version 2.0.0, which fixes the issue.

Weakness: CWE-359

Which versions are affected by CVE-2026-24735?

3 open source packages ship an affected version, including github.com/apache/answer. It affects 1 product.

PackageAffectedFixed in
github.com/apache/answer GoAll versionsNone
github.com/apache/answer GoAll versions2.0.0
github.com/apache/answer GoAll versions2.0.0

Products include Apache Answer.

How do I fix CVE-2026-24735?

Upgrade github.com/apache/answer to 2.0.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-24735 being exploited?

There is no known exploitation of CVE-2026-24735 in the wild and no public exploit code.

Sources

Also known as GHSA-5w5r-8xc6-2xhw, GO-2026-4421.

Is CVE-2026-24735 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free