CVE-2026-24739 Symfony has incorrect argument escaping under MSYS2/Git Bash on Windows that can lead to destructive file operations
Attackers can trigger destructive file operations by exploiting argument escaping flaws in Symfony Process when running under MSYS2/Git Bash on Windows.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-24739?
CVE-2026-24739 is a medium-severity command injection vulnerability in Sensiolabs Symfony, published on 28 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to versions 5.4.51, 6.4.33, 7.3.11, 7.4.5, and 8.0.5, the Symfony Process component did not correctly treat some characters (notably `=`) as “special” when escaping arguments on Windows. When PHP is executed from an MSYS2-based environment (e.g. Git Bash) and Symfony Process spawns native Windows executables, MSYS2’s argument/path conversion can mis-handle unquoted arguments containing these characters. This can cause the spawned process to receive corrupted/truncated arguments compared to what Symfony intended. If an application (or tooling such as Composer scripts) uses Symfony Process to invoke file-management commands (e.g. `rmdir`, `del`, etc.) with a path argument containing `=`, the MSYS2 conversion layer may alter the argument at runtime. In affected setups this can result in operations being performed on an unintended path, up to and including deletion of the contents of a broader directory or drive. The issue is particularly relevant when untrusted input can influence process arguments (directly or indirectly, e.g. via repository paths, extracted archive paths, temporary directories, or user-controlled configuration). Versions 5.4.51, 6.4.33, 7.3.11, 7.4.5, and 8.0.5 contains a patch for the issue. Some workarounds are available. Avoid running PHP/one's own tooling from MSYS2-based shells on Windows; prefer cmd.exe or PowerShell for workflows that spawn native executables. Avoid passing paths containing `=` (and similar MSYS2-sensitive characters) to Symfony Process when operating under Git Bash/MSYS2. Where applicable, configure MSYS2 to disable or restrict argument conversion (e.g. via `MSYS2_ARG_CONV_EXCL`), understanding this may affect other tooling behavior.
Weakness: CWE-88
Which versions are affected by CVE-2026-24739?
20 open source packages ship an affected version, including symfony/process and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/process Packagist | All versions | 5.4.51 |
symfony/process Packagist | All versions | 5.4.51 |
symfony/process Packagist | From 6.4 | 6.4.33 |
symfony/process Packagist | From 6.4 | 6.4.33 |
symfony/process Packagist | From 7.3 | 7.3.11 |
symfony/process Packagist | From 7.3 | 7.3.11 |
14 more packages
symfony/process Packagist | From 7.4 | 7.4.5 |
symfony/process Packagist | From 7.4 | 7.4.5 |
symfony/process Packagist | From 8.0 | 8.0.5 |
symfony/process Packagist | From 8.0 | 8.0.5 |
symfony/symfony Packagist | All versions | 5.4.51 |
symfony/symfony Packagist | All versions | 5.4.51 |
symfony/symfony Packagist | From 6.4 | 6.4.33 |
symfony/symfony Packagist | From 6.4 | 6.4.33 |
symfony/symfony Packagist | From 7.3 | 7.3.11 |
symfony/symfony Packagist | From 7.3 | 7.3.11 |
symfony/symfony Packagist | From 7.4 | 7.4.5 |
symfony/symfony Packagist | From 7.4 | 7.4.5 |
symfony/symfony Packagist | From 8.0 | 8.0.5 |
symfony/symfony Packagist | From 8.0 | 8.0.5 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-24739?
Upgrade symfony/process to a fixed version for your release line: 5.4.51, 6.4.33, 7.3.11 or 7.4.5.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-24739 being exploited?
There is no known exploitation of CVE-2026-24739 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as CLSA-2026-1771808253, CLSA-2026-1771894652, GHSA-r39x-jcww-82v6.