# CVE-2026-24742: Discourse staff action logs expose sensitive information to moderators

> Moderators can view sensitive admin-only data in staff logs, exposing secrets and private content, requiring an upgrade to restrict access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-discourse-2026-24742, GHSA-hwjv-9gqj-m7h6

## What is CVE-2026-24742?

CVE-2026-24742 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, non-admin moderators can view sensitive information in staff action logs that should be restricted to administrators only. The exposed information includes webhook payload URLs and secrets, API key details, site setting changes, private message content, restricted category names and structures, and private chat channel titles. This allows moderators to bypass intended access controls and extract confidential data by monitoring the staff action logs. With leaked webhook secrets, an attacker could potentially spoof webhook events to integrated services. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, site administrators should review and limit moderator appointments to fully trusted users. There is no configuration-based workaround to prevent this access.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-24742?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0 |

Products: Discourse Discourse.

## How do I fix CVE-2026-24742?

Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.

## Is CVE-2026-24742 being exploited?

There is no known exploitation of CVE-2026-24742 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24742 and fix it if it is affected.

What it is: CVE-2026-24742 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24742 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24742/ (Markdown: https://insights.sbomify.com/CVE-2026-24742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24742
- OSV: https://osv.dev/vulnerability/CVE-2026-24742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24742/
Summaries are generated and may contain mistakes; the official description above is the record.
