# CVE-2026-2476: MS Teams plugin sensitive config values not properly masked in support packets

> Attackers with access to support packets can obtain unmasked sensitive plugin configuration values from Mattermost plugins.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-4ppj-6chv-5pgc, GO-2026-4784

## What is CVE-2026-2476?

CVE-2026-2476 is a high-severity vulnerability in Mattermost, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost Plugins versions <=2.0.3.0 fail to properly mask sensitive configuration values which allows an attacker with access to support packets to obtain original plugin settings via exported configuration data. Mattermost Advisory ID: MMSA-2026-00606

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-2476?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-msteams. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 1.15.1-0.20260102165339-036c761bd3cb |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 1.15.1-0.20260102165339-036c761bd3cb |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 1.15.1-0.20260102165339-036c761bd3cb |

Products: Mattermost Ms Teams.

## How do I fix CVE-2026-2476?

Upgrade github.com/mattermost/mattermost-plugin-msteams to 1.15.1-0.20260102165339-036c761bd3cb or later.

## Is CVE-2026-2476 being exploited?

There is no known exploitation of CVE-2026-2476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2476 and fix it if it is affected.

What it is: CVE-2026-2476 is a high-severity vulnerability in Mattermost, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2476 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 1.15.1-0.20260102165339-036c761bd3cb
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 1.15.1-0.20260102165339-036c761bd3cb
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 1.15.1-0.20260102165339-036c761bd3cb

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2476/ (Markdown: https://insights.sbomify.com/CVE-2026-2476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2476
- OSV: https://osv.dev/vulnerability/CVE-2026-2476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2476/
Summaries are generated and may contain mistakes; the official description above is the record.
