# CVE-2026-24765: PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling

> An attacker with local file write access can achieve arbitrary code execution by placing malicious serialized data in code coverage files during PHPT test runs.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 6 Feb 2026
- **Also known as:** CLSA-2026-1771980787, CLSA-2026-1773276786, CLSA-2026-1776732788, CLSA-2026-1776818215, CLSA-2026-1776818222, CLSA-2026-1776818223, CLSA-2026-1776819190, CLSA-2026-1779151615, DEBIAN-CVE-2026-24765, DLA-4470-1, GHSA-vvj3-c3rp-c85p, UBUNTU-CVE-2026-24765

## What is CVE-2026-24765?

CVE-2026-24765 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 27 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PHPUnit is a testing framework for PHP. A vulnerability has been discovered in versions prior to 12.5.8, 11.5.50, 10.5.62, 9.6.33, and 8.5.52 involving unsafe deserialization of code coverage data in PHPT test execution. The vulnerability exists in the `cleanupForCoverage()` method, which deserializes code coverage files without validation, potentially allowing remote code execution if malicious `.coverage` files are present prior to the execution of the PHPT test. The vulnerability occurs when a `.coverage` file, which should not exist before test execution, is deserialized without the `allowed_classes` parameter restriction. An attacker with local file write access can place a malicious serialized object with a `__wakeup()` method into the file system, leading to arbitrary code execution during test runs with code coverage instrumentation enabled. This vulnerability requires local file write access to the location where PHPUnit stores or expects code coverage files for PHPT tests. This can occur through CI/CD pipeline attacks, the local development environment, and/or compromised dependencies. Rather than just silently sanitizing the input via `['allowed_classes' => false]`, the maintainer has chosen to make the anomalous state explicit by treating pre-existing `.coverage` files for PHPT tests as an error condition. Starting in versions  in versions 12.5.8, 11.5.50, 10.5.62, 9.6.33, when a `.coverage` file is detected for a PHPT test prior to execution, PHPUnit will emit a clear error message identifying the anomalous state. Organizations can reduce the effective risk of this vulnerability through proper CI/CD configuration, including ephemeral runners, code review enforcement, branch protection, artifact isolation, and access control.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-24765?

10 open source packages ship an affected version, including phpunit/phpunit. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpunit/phpunit` | Packagist | All versions | 8.5.52 |
| `phpunit/phpunit` | Packagist | All versions | 8.5.52 |
| `phpunit/phpunit` | Packagist | From 10.0.0 | 10.5.62 |
| `phpunit/phpunit` | Packagist | From 10.0.0 | 10.5.62 |
| `phpunit/phpunit` | Packagist | From 11.0.0 | 11.5.50 |
| `phpunit/phpunit` | Packagist | From 11.0.0 | 11.5.50 |
| `phpunit/phpunit` | Packagist | From 12.0.0 | 12.5.8 |
| `phpunit/phpunit` | Packagist | From 12.0.0 | 12.5.8 |
| `phpunit/phpunit` | Packagist | From 9.0.0 | 9.6.33 |
| `phpunit/phpunit` | Packagist | From 9.0.0 | 9.6.33 |

Products: Debian Debian Linux, Phpunit Project Phpunit.

## How do I fix CVE-2026-24765?

Upgrade phpunit/phpunit to a fixed version for your release line: 8.5.52, 10.5.62, 11.5.50 or 12.5.8.

## Is CVE-2026-24765 being exploited?

There is no known exploitation of CVE-2026-24765 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24765 and fix it if it is affected.

What it is: CVE-2026-24765 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 27 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24765 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpunit/phpunit (Packagist): affected all versions; fixed in 8.5.52
- phpunit/phpunit (Packagist): affected all versions; fixed in 8.5.52
- phpunit/phpunit (Packagist): affected from 10.0.0; fixed in 10.5.62
- phpunit/phpunit (Packagist): affected from 10.0.0; fixed in 10.5.62
- phpunit/phpunit (Packagist): affected from 11.0.0; fixed in 11.5.50
- phpunit/phpunit (Packagist): affected from 11.0.0; fixed in 11.5.50
- phpunit/phpunit (Packagist): affected from 12.0.0; fixed in 12.5.8
- phpunit/phpunit (Packagist): affected from 12.0.0; fixed in 12.5.8
- phpunit/phpunit (Packagist): affected from 9.0.0; fixed in 9.6.33
- phpunit/phpunit (Packagist): affected from 9.0.0; fixed in 9.6.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24765/ (Markdown: https://insights.sbomify.com/CVE-2026-24765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24765
- OSV: https://osv.dev/vulnerability/CVE-2026-24765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24765/
Summaries are generated and may contain mistakes; the official description above is the record.
