# CVE-2026-24767: NocoDB has Blind SSRF via Unvalidated HEAD Request in uploadViaURL Functionality

> Attackers can trigger blind SSRF via unvalidated HEAD requests in NocoDB's uploadViaURL feature, bypassing initial security controls.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 29 Jan 2026
- **Also known as:** GHSA-xr7v-j379-34v9

## What is CVE-2026-24767?

CVE-2026-24767 is a medium-severity server-side request forgery vulnerability in nocodb, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to version 0.301.0, a blind Server-Side Request Forgery (SSRF) vulnerability exists in the `uploadViaURL` functionality due to an unprotected `HEAD` request. While the subsequent file retrieval logic correctly enforces SSRF protections, the initial metadata request executes without validation. This allows limited outbound requests to arbitrary URLs before SSRF controls are applied. Version 0.301.0 contains a patch for the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-24767?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.301.0 |
| `nocodb` | npm | All versions | 0.301.0 |

Products: Nocodb Nocodb.

## How do I fix CVE-2026-24767?

Upgrade nocodb to 0.301.0 or later.

## Is CVE-2026-24767 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24767 exists.

## Other vulnerabilities in nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24767 and fix it if it is affected.

What it is: CVE-2026-24767 is a medium-severity server-side request forgery vulnerability in nocodb, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24767 exists.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.301.0
- nocodb (npm): affected all versions; fixed in 0.301.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24767/ (Markdown: https://insights.sbomify.com/CVE-2026-24767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24767
- OSV: https://osv.dev/vulnerability/CVE-2026-24767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24767/
Summaries are generated and may contain mistakes; the official description above is the record.
