# CVE-2026-24768: NocoDB has Unvalidated Redirect in Login Flow via continueAfterSignIn Parameter

> Attackers can redirect authenticated users to malicious sites via the login flow, facilitating phishing attacks in NocoDB.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 29 Jan 2026
- **Also known as:** GHSA-3hmw-8mw3-rmpj

## What is CVE-2026-24768?

CVE-2026-24768 is a medium-severity vulnerability in nocodb, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to version 0.301.0, an unvalidated redirect (open redirect) vulnerability exists in NocoDB’s login flow due to missing validation of the `continueAfterSignIn` parameter. During authentication, NocoDB processes a user-controlled redirect value and conditionally performs client-side navigation without enforcing any restrictions on the destination’s origin, domain or protocol. This allows attackers to redirect authenticated users to arbitrary external websites after login. This vulnerability enables phishing attacks by leveraging user trust in the legitimate NocoDB login flow. While it does not directly expose credentials or bypass authentication, it increases the likelihood of credential theft through social engineering. The issue does not allow arbitrary code execution or privilege escalation, but it undermines authentication integrity. Version 0.301.0 fixes the issue.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-24768?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.301.0 |
| `nocodb` | npm | All versions | 0.301.0 |

Products: Nocodb Nocodb.

## How do I fix CVE-2026-24768?

Upgrade nocodb to 0.301.0 or later.

## Is CVE-2026-24768 being exploited?

There is no known exploitation of CVE-2026-24768 in the wild and no public exploit code.

## Other vulnerabilities in nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24768 and fix it if it is affected.

What it is: CVE-2026-24768 is a medium-severity vulnerability in nocodb, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24768 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.301.0
- nocodb (npm): affected all versions; fixed in 0.301.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24768/ (Markdown: https://insights.sbomify.com/CVE-2026-24768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24768
- OSV: https://osv.dev/vulnerability/CVE-2026-24768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24768/
Summaries are generated and may contain mistakes; the official description above is the record.
