# CVE-2026-24778: Ghost vulnerable to XSS via malicious Portal preview links

> Attackers can execute JavaScript via malicious Portal preview links, leading to account takeover for authenticated users in Ghost CMS.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-ghost-2026-24778, GHSA-gv6q-2m97-882h

## What is CVE-2026-24778?

CVE-2026-24778 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ghost is an open source content management system. In Ghost versions 5.43.0 through 5.12.04 and 6.0.0 through 6.14.0, an attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. Ghost Portal versions 2.29.1 through 2.51.4 and 2.52.0 through 2.57.0 were vulnerable to this issue. Ghost automatically loads the latest patch of the members Portal component via CDN. For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability. v5.121.0 loads Portal v2.51.5, which contains the patch. For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability. v6.15.0 loads Portal v2.57.1, which contains the patch. For Ghost installations using a customized or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-24778?

9 open source packages ship an affected version, including @tryghost/portal and ghost. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tryghost/portal` | npm | From 2.29.1 | 2.51.5 |
| `@tryghost/portal` | npm | From 2.29.1 | 2.51.5 |
| `@tryghost/portal` | npm | From 2.52.0 | 2.57.1 |
| `@tryghost/portal` | npm | From 2.52.0 | 2.57.1 |
| `ghost` | Bitnami | From 5.43.0 | 5.121.0, 6.15.0 |
| `ghost` | npm | From 5.43.0 | 5.121.0 |
| `ghost` | npm | From 5.43.0 | 5.121.0 |
| `ghost` | npm | From 6.0.0 | 6.15.0 |
| `ghost` | npm | From 6.0.0 | 6.15.0 |

Products: Ghost Ghost, Ghost Portal.

## How do I fix CVE-2026-24778?

Upgrade @tryghost/portal to a fixed version for your release line: 2.51.5 or 2.57.1.

## Is CVE-2026-24778 being exploited?

There is no known exploitation of CVE-2026-24778 in the wild and no public exploit code.

## Other vulnerabilities in TryGhost Ghost

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24778 and fix it if it is affected.

What it is: CVE-2026-24778 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-24778 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tryghost/portal (npm): affected from 2.29.1; fixed in 2.51.5
- @tryghost/portal (npm): affected from 2.29.1; fixed in 2.51.5
- @tryghost/portal (npm): affected from 2.52.0; fixed in 2.57.1
- @tryghost/portal (npm): affected from 2.52.0; fixed in 2.57.1
- ghost (Bitnami): affected from 5.43.0; fixed in 5.121.0, 6.15.0
- ghost (npm): affected from 5.43.0; fixed in 5.121.0
- ghost (npm): affected from 5.43.0; fixed in 5.121.0
- ghost (npm): affected from 6.0.0; fixed in 6.15.0
- ghost (npm): affected from 6.0.0; fixed in 6.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24778/ (Markdown: https://insights.sbomify.com/CVE-2026-24778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24778
- OSV: https://osv.dev/vulnerability/CVE-2026-24778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24778/
Summaries are generated and may contain mistakes; the official description above is the record.
