# CVE-2026-24779: vLLM vulnerable to Server-Side Request Forgery (SSRF) in `MediaConnector`

> Attackers can bypass host restrictions in vLLM's MediaConnector to force the server to make arbitrary requests to internal network resources.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-qh4c-xf7m-gxfc, PYSEC-2026-2020

## What is CVE-2026-24779?

CVE-2026-24779 is a high-severity server-side request forgery vulnerability in Vllm Vllm, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to version 0.14.1, a Server-Side Request Forgery (SSRF) vulnerability exists in the `MediaConnector` class within the vLLM project's multimodal feature set. The load_from_url and load_from_url_async methods obtain and process media from URLs provided by users, using different Python parsing libraries when restricting the target host. These two parsing libraries have different interpretations of backslashes, which allows the host name restriction to be bypassed. This allows an attacker to coerce the vLLM server into making arbitrary requests to internal network resources. This vulnerability is particularly critical in containerized environments like `llm-d`, where a compromised vLLM pod could be used to scan the internal network, interact with other pods, and potentially cause denial of service or access sensitive data. For example, an attacker could make the vLLM pod send malicious requests to an internal `llm-d` management endpoint, leading to system instability by falsely reporting metrics like the KV cache state. Version 0.14.1 contains a patch for the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-24779?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.14.1 |
| `vllm` | PyPI | All versions | 0.14.1 |
| `vllm` | PyPI | All versions | 0.14.1 |

Products: Vllm Vllm.

## How do I fix CVE-2026-24779?

Upgrade vllm to 0.14.1 or later.

## Is CVE-2026-24779 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24779 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24779 and fix it if it is affected.

What it is: CVE-2026-24779 is a high-severity server-side request forgery vulnerability in Vllm Vllm, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24779 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.14.1
- vllm (PyPI): affected all versions; fixed in 0.14.1
- vllm (PyPI): affected all versions; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24779/ (Markdown: https://insights.sbomify.com/CVE-2026-24779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24779
- OSV: https://osv.dev/vulnerability/CVE-2026-24779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24779/
Summaries are generated and may contain mistakes; the official description above is the record.
