CVE-2026-24784 DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer

Medium 6.8 Published Updated

A content editor can inject malicious scripts into module headers or footers, allowing execution in other users' browsers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-24784?

CVE-2026-24784 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, a content editor could inject scripts in module headers/footers that would run for other users. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

Weakness: CWE-79

Which versions are affected by CVE-2026-24784?

4 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.

PackageAffectedFixed in
DotNetNuke.Core NuGetFrom 10.0.010.2.0
DotNetNuke.Core NuGetFrom 10.0.010.2.0
DotNetNuke.Core NuGetFrom 9.0.09.13.10
DotNetNuke.Core NuGetFrom 9.0.09.13.10

Products include Dnnsoftware Dotnetnuke.

How do I fix CVE-2026-24784?

Upgrade DotNetNuke.Core to a fixed version for your release line: 10.2.0 or 9.13.10.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-24784 being exploited?

There is no known exploitation of CVE-2026-24784 in the wild and no public exploit code.

All Dnnsoftware Dotnetnuke vulnerabilities

Sources

Also known as GHSA-jjwg-4948-6wxp.

Is CVE-2026-24784 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free