{"answers":{"affected":"2 open source packages ship an affected version, including clatter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24785 in the wild and no public exploit code.","fix":"Upgrade clatter to 2.2.0 or later.","what":"CVE-2026-24785 is a high-severity vulnerability in jmlepisto clatter, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24785 and fix it if it is affected.\n\nWhat it is: CVE-2026-24785 is a high-severity vulnerability in jmlepisto clatter, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24785 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- clatter (crates.io): affected all versions; fixed in 2.2.0\n- clatter (crates.io): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24785/ (Markdown: https://insights.sbomify.com/CVE-2026-24785/index.md)","id":"CVE-2026-24785","markdown":"https://insights.sbomify.com/CVE-2026-24785/index.md","name":"CVE-2026-24785","record":{"aliases":["GHSA-253q-9q78-63x4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust Noise protocol library","requires_auth":"none","summary":"Clatter library allowed PSK handshake patterns violating protocol rules, potentially enabling key reuse and weakening encryption security.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"clatter","vendor":"jmlepisto"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"Clatter is a no_std compatible, pure Rust implementation of the Noise protocol framework with post-quantum support. Versiosn prior to2.2.0 have a protocol compliance vulnerability. The library allowed post-quantum handshake patterns that violated the PSK validity rule (Noise Protocol Framework Section 9.3). This could allow PSK-derived keys to be used for encryption without proper randomization by self-chosen ephemeral randomness, weakening security guarantees and potentially allowing catastrophic key reuse. Affected default patterns include `noise_pqkk_psk0`, `noise_pqkn_psk0`, `noise_pqnk_psk0`, `noise_pqnn_psk0``, and some hybrid variants. Users of these patterns may have been using handshakes that do not meet the intended security properties. The issue is fully patched and released in Clatter v2.2.0. The fixed version includes runtime checks to detect offending handshake patterns. As a workaround, avoid using offending `*_psk0` variants of post-quantum patterns. Review custom handshake patterns carefully.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Clatter has a PSK Validity Rule Violation issue","id":"CVE-2026-24785","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"RaspAP raspap-webgui contains an OS Command Injection vulnerability","id":"CVE-2026-24788"},"packages":[{"ecosystem":"crates.io","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"clatter","purl":null,"source":"GHSA-253q-9q78-63x4"},{"ecosystem":"crates.io","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"clatter","purl":"pkg:cargo/clatter","source":"GHSA-253q-9q78-63x4"}],"prev":{"headline":"DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer","id":"CVE-2026-24784"},"products":["clatter"],"published":"2026-01-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-28","vendors":["jmlepisto"]},"summary":"Clatter library allowed PSK handshake patterns violating protocol rules, potentially enabling key reuse and weakening encryption security.","url":"https://insights.sbomify.com/CVE-2026-24785/"}