# CVE-2026-24802: Buffer Overflow Vulnerability in briandilley/jsonrpc4j

> An infinite loop in the NoCloseOutputStream class allows attackers to cause a denial of service in applications using the jsonrpc4j library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:L/AU:Y/R:A/V:D/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-hcx3-3q5c-r5v6

## What is CVE-2026-24802?

CVE-2026-24802 is a medium-severity denial of service vulnerability in briandilley jsonrpc4j, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in briandilley jsonrpc4j (src/main/java/com/googlecode/jsonrpc4j modules). This vulnerability is associated with program files NoCloseOutputStream.Java.

This issue affects jsonrpc4j: through 1.6.0.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-24802?

2 open source packages ship an affected version, including com.github.briandilley.jsonrpc4j:jsonrpc4j.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.github.briandilley.jsonrpc4j:jsonrpc4j` | Maven | All versions | 1.7.0 |
| `com.github.briandilley.jsonrpc4j:jsonrpc4j` | Maven | All versions | 1.7.0 |

## How do I fix CVE-2026-24802?

Upgrade com.github.briandilley.jsonrpc4j:jsonrpc4j to 1.7.0 or later.

## Is CVE-2026-24802 being exploited?

There is no known exploitation of CVE-2026-24802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24802 and fix it if it is affected.

What it is: CVE-2026-24802 is a medium-severity denial of service vulnerability in briandilley jsonrpc4j, published on 27 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-24802 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.github.briandilley.jsonrpc4j:jsonrpc4j (Maven): affected all versions; fixed in 1.7.0
- com.github.briandilley.jsonrpc4j:jsonrpc4j (Maven): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24802/ (Markdown: https://insights.sbomify.com/CVE-2026-24802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24802
- OSV: https://osv.dev/vulnerability/CVE-2026-24802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24802/
Summaries are generated and may contain mistakes; the official description above is the record.
