# CVE-2026-24834: Kata Container to Guest micro VM privilege escalation

> A container user can modify the guest micro VM file system to achieve arbitrary code execution as root within the VM.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** AZL-77976, GHSA-wwj6-vghv-5p64, GO-2026-4517

## What is CVE-2026-24834?

CVE-2026-24834 is a critical vulnerability in kata-containers, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Kata Containers is an open source project focusing on a standard implementation of lightweight Virtual Machines (VMs) that perform like containers. In versions prior to 3.27.0, an issue in Kata with Cloud Hypervisor allows a user of the container to modify the file system used by the Guest micro VM ultimately achieving arbitrary code execution as root in said VM. The current understanding is this doesn’t impact the security of the Host or of other containers / VMs running on that Host (note that arm64 QEMU lacks NVDIMM read-only support: It is believed that until the upstream QEMU gains this capability, a guest write could reach the image file). Version 3.27.0 patches the issue.

Weakness: CWE-281 (Improper Preservation of Permissions), CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-24834?

3 open source packages ship an affected version, including github.com/kata-containers/kata-containers/src/runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kata-containers/kata-containers/src/runtime` | Go | All versions | 0.0.0-20260219090056-6a672503973b |
| `github.com/kata-containers/kata-containers/src/runtime` | Go | All versions | 0.0.0-20260219090056-6a672503973b |
| `github.com/kata-containers/kata-containers/src/runtime` | Go | All versions | 0.0.0-20260219090056-6a672503973b |

Products: Katacontainers Kata Containers.

## How do I fix CVE-2026-24834?

Upgrade github.com/kata-containers/kata-containers/src/runtime to 0.0.0-20260219090056-6a672503973b or later.

## Is CVE-2026-24834 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24834 exists.

## Other vulnerabilities in kata-containers

- [CVE-2026-24054](https://insights.sbomify.com/CVE-2026-24054/): Other in kata-containers (high 8.8)
- [CVE-2020-27151](https://insights.sbomify.com/CVE-2020-27151/): Code injection in n/a (high 8.8)
- [CVE-2026-44210](https://insights.sbomify.com/CVE-2026-44210/): Kata Containers have VM Escape via virtiofsd Argument Injection through Default-Enabled Pod Annotations (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24834 and fix it if it is affected.

What it is: CVE-2026-24834 is a critical vulnerability in kata-containers, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24834 exists.

Affected packages and fixed versions:
- github.com/kata-containers/kata-containers/src/runtime (Go): affected all versions; fixed in 0.0.0-20260219090056-6a672503973b
- github.com/kata-containers/kata-containers/src/runtime (Go): affected all versions; fixed in 0.0.0-20260219090056-6a672503973b
- github.com/kata-containers/kata-containers/src/runtime (Go): affected all versions; fixed in 0.0.0-20260219090056-6a672503973b

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24834/ (Markdown: https://insights.sbomify.com/CVE-2026-24834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24834
- OSV: https://osv.dev/vulnerability/CVE-2026-24834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24834/
Summaries are generated and may contain mistakes; the official description above is the record.
