{"answers":{"affected":"4 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24836 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to 10.02.0 or later.","what":"CVE-2026-24836 is a high-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-24836 and fix it if it is affected.\n\nWhat it is: CVE-2026-24836 is a high-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-24836 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected from 10.0.0; fixed in 10.02.0\n- DotNetNuke.Core (NuGet): affected from 10.0.0; fixed in 10.02.0\n- DotNetNuke.Core (NuGet): affected from 9.0.0 up to 9.13.9; no fix listed\n- DotNetNuke.Core (NuGet): affected from 9.0.0 up to 9.13.9; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24836/ (Markdown: https://insights.sbomify.com/CVE-2026-24836/index.md)","id":"CVE-2026-24836","markdown":"https://insights.sbomify.com/CVE-2026-24836/index.md","name":"CVE-2026-24836","record":{"aliases":["GHSA-2g5g-hcgh-q3rp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DNN CMS","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into scheduler log notes, leading to stored XSS execution in the admin interface.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, extensions could write richtext in log notes which can include scripts that would run in the PersonaBar when displayed. Versions 9.13.10 and 10.2.0 contain a fix for the issue.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DotNetNuke.Core Vulnerable to Stored XSS in Scheduler LogNotes","id":"CVE-2026-24836","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"DotNetNuke.Core Vulnerable to Stored XSS in Module Deletion Confirmation Modal","id":"CVE-2026-24837"},"packages":[{"ecosystem":"NuGet","fixed":["10.02.0"],"introduced":["10.0.0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-2g5g-hcgh-q3rp"},{"ecosystem":"NuGet","fixed":["10.02.0"],"introduced":["10.0.0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-2g5g-hcgh-q3rp"},{"ecosystem":"NuGet","fixed":[],"introduced":["9.0.0"],"last_affected":["9.13.9"],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-2g5g-hcgh-q3rp"},{"ecosystem":"NuGet","fixed":[],"introduced":["9.0.0"],"last_affected":["9.13.9"],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-2g5g-hcgh-q3rp"}],"prev":{"headline":"Podman Desktop Extension System Vulnerable to Authentication Bypass","id":"CVE-2026-24835"},"products":["Dnn.Platform"],"published":"2026-01-27","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-28","vendors":["dnnsoftware"]},"summary":"Attackers can inject malicious scripts into scheduler log notes, leading to stored XSS execution in the admin interface.","url":"https://insights.sbomify.com/CVE-2026-24836/"}