# CVE-2026-24836: DotNetNuke.Core Vulnerable to Stored XSS in Scheduler LogNotes

> Attackers can inject malicious scripts into scheduler log notes, leading to stored XSS execution in the admin interface.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** GHSA-2g5g-hcgh-q3rp

## What is CVE-2026-24836?

CVE-2026-24836 is a high-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, extensions could write richtext in log notes which can include scripts that would run in the PersonaBar when displayed. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-24836?

4 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | From 10.0.0 | 10.02.0 |
| `DotNetNuke.Core` | NuGet | From 10.0.0 | 10.02.0 |
| `DotNetNuke.Core` | NuGet | From 9.0.0 to 9.13.9 | None |
| `DotNetNuke.Core` | NuGet | From 9.0.0 to 9.13.9 | None |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2026-24836?

Upgrade DotNetNuke.Core to 10.02.0 or later.

## Is CVE-2026-24836 being exploited?

There is no known exploitation of CVE-2026-24836 in the wild and no public exploit code.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24836 and fix it if it is affected.

What it is: CVE-2026-24836 is a high-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-24836 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected from 10.0.0; fixed in 10.02.0
- DotNetNuke.Core (NuGet): affected from 10.0.0; fixed in 10.02.0
- DotNetNuke.Core (NuGet): affected from 9.0.0 up to 9.13.9; no fix listed
- DotNetNuke.Core (NuGet): affected from 9.0.0 up to 9.13.9; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24836/ (Markdown: https://insights.sbomify.com/CVE-2026-24836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24836
- OSV: https://osv.dev/vulnerability/CVE-2026-24836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24836/
Summaries are generated and may contain mistakes; the official description above is the record.
