# CVE-2026-24838: DotNetNuke.Core Vulnerable to Stored XSS via Module Title

> Attackers can inject malicious scripts into module titles, leading to stored XSS attacks against other users of the DNN platform.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** GHSA-w9pf-h6m6-v89h

## What is CVE-2026-24838?

CVE-2026-24838 is a critical cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to versions 9.13.10 and 10.2.0,  module title supports richtext which could include scripts that would execute in certain scenarios. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-24838?

4 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.13.10 |
| `DotNetNuke.Core` | NuGet | All versions | 9.13.10 |
| `DotNetNuke.Core` | NuGet | From 10.0.0 | 10.2.0 |
| `DotNetNuke.Core` | NuGet | From 10.0.0 | 10.2.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2026-24838?

Upgrade DotNetNuke.Core to a fixed version for your release line: 9.13.10 or 10.2.0.

## Is CVE-2026-24838 being exploited?

There is no known exploitation of CVE-2026-24838 in the wild and no public exploit code.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24838 and fix it if it is affected.

What it is: CVE-2026-24838 is a critical cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 27 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24838 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.13.10
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.13.10
- DotNetNuke.Core (NuGet): affected from 10.0.0; fixed in 10.2.0
- DotNetNuke.Core (NuGet): affected from 10.0.0; fixed in 10.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24838/ (Markdown: https://insights.sbomify.com/CVE-2026-24838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24838
- OSV: https://osv.dev/vulnerability/CVE-2026-24838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24838/
Summaries are generated and may contain mistakes; the official description above is the record.
