# CVE-2026-24842: node-tar Vulnerable to Arbitrary File Creation/Overwrite via Hardlink Path Traversal

> Attackers can exploit a path traversal flaw in node-tar to create hardlinks to arbitrary files, potentially leading to data modification or code execution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 7 Sep 2026
- **Also known as:** CLEANSTART-2026-RV26689, CLEANSTART-2026-WI35354, DEBIAN-CVE-2026-24842, ECHO-60e5-49eb-41f5, GHSA-34x7-hfp2-rc4v, MINI-27cj-2277-vcqf, MINI-328c-g55r-hwc3, MINI-3j67-pwmc-h66x, MINI-3j82-xf2r-33hj, MINI-5xg4-pqx8-4cq3, MINI-6mqc-7538-w55r, MINI-7354-wgf2-4whh, MINI-778q-r5fv-p9m9, MINI-8g26-fp85-p3r5, MINI-8x94-qqg3-j72p, MINI-947f-mrph-26qc, MINI-9rp5-4p8h-2xf8, MINI-f732-fjp5-2wc9, MINI-f829-7rhr-g7ph, MINI-jjfq-74w5-mp64, MINI-m5xp-8pmg-rq43, MINI-m82f-p574-496f, MINI-mgq4-j4m5-jx5v, MINI-p6g5-px2m-8wmc, MINI-p8mm-8xp2-f5g4, MINI-p964-962p-cxcr, MINI-vm3g-pjgx-cxpx, MINI-w7jx-5mx3-cgmm, MINI-wfg6-w6jv-p7qq, MINI-x3p9-68v6-g56j, ROOT-APP-NPM-CVE-2026-24842, UBUNTU-CVE-2026-24842, openSUSE-SU-2026:10410-1

## What is CVE-2026-24842?

CVE-2026-24842 is a high-severity path traversal vulnerability in isaacs node-tar, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

node-tar,a Tar for Node.js, contains a vulnerability in versions prior to 7.5.7 where the security check for hardlink entries uses different path resolution semantics than the actual hardlink creation logic. This mismatch allows an attacker to craft a malicious TAR archive that bypasses path traversal protections and creates hardlinks to arbitrary files outside the extraction directory. Version 7.5.7 contains a fix for the issue.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-24842?

2 open source packages ship an affected version, including tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | npm | All versions | 7.5.7 |
| `tar` | npm | All versions | 7.5.7 |
| `pnpm` | openSUSE:Tumbleweed | All versions | 10.32.1-1.1 |

Products: Isaacs Tar.

## How do I fix CVE-2026-24842?

Upgrade tar to 7.5.7 or later.

## Is CVE-2026-24842 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24842 exists.

## Other vulnerabilities in isaacs node-tar

- [CVE-2026-59873](https://insights.sbomify.com/CVE-2026-59873/): node-tar: Decompression/parse DoS via unlimited input (critical 9.2)
- [CVE-2026-23950](https://insights.sbomify.com/CVE-2026-23950/): node-tar has Race Condition in Path Reservations via Unicode Ligature Collisions on macOS APFS (high 8.8)
- [CVE-2026-59874](https://insights.sbomify.com/CVE-2026-59874/): node-tar: Negative tar entry size causes infinite loop in archive replace (high 8.7)
- [CVE-2026-31802](https://insights.sbomify.com/CVE-2026-31802/): node-tar Symlink Path Traversal via Drive-Relative Linkpath (high 8.2)
- [CVE-2026-29786](https://insights.sbomify.com/CVE-2026-29786/): node-tar: Hardlink Path Traversal via Drive-Relative Linkpath (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24842 and fix it if it is affected.

What it is: CVE-2026-24842 is a high-severity path traversal vulnerability in isaacs node-tar, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24842 exists.

Affected packages and fixed versions:
- tar (npm): affected all versions; fixed in 7.5.7
- tar (npm): affected all versions; fixed in 7.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24842/ (Markdown: https://insights.sbomify.com/CVE-2026-24842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24842
- OSV: https://osv.dev/vulnerability/CVE-2026-24842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24842/
Summaries are generated and may contain mistakes; the official description above is the record.
