{"answers":{"affected":"2 open source packages ship an affected version, including ml-dsa.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24850 exists.","fix":"Upgrade ml-dsa to 0.1.0-rc.4 or later.","what":"CVE-2026-24850 is a medium-severity vulnerability in RustCrypto signatures, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24850 and fix it if it is affected.\n\nWhat it is: CVE-2026-24850 is a medium-severity vulnerability in RustCrypto signatures, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24850 exists.\n\nAffected packages and fixed versions:\n- ml-dsa (crates.io): affected from 0.0.4; fixed in 0.1.0-rc.4\n- ml-dsa (crates.io): affected from 0.0.4; fixed in 0.1.0-rc.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24850/ (Markdown: https://insights.sbomify.com/CVE-2026-24850/index.md)","id":"CVE-2026-24850","markdown":"https://insights.sbomify.com/CVE-2026-24850/index.md","name":"CVE-2026-24850","record":{"aliases":["GHSA-5x2r-hc65-25f9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust ML-DSA library","requires_auth":"none","summary":"Attackers can bypass signature verification in the ML-DSA Rust library by submitting signatures with duplicate hint indices, violating FIPS 204 standards.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"The ML-DSA crate is a Rust implementation of the Module-Lattice-Based Digital Signature Standard (ML-DSA). Starting in version 0.0.4 and prior to version 0.1.0-rc.4, the ML-DSA signature verification implementation in the RustCrypto `ml-dsa` crate incorrectly accepts signatures with repeated (duplicate) hint indices. According to the ML-DSA specification (FIPS 204 / RFC 9881), hint indices within each polynomial must be **strictly increasing**. The current implementation uses a non-strict monotonic check (`\u003c=` instead of `\u003c`), allowing duplicate indices. This is a regression bug. The original implementation was correct, but a commit in version 0.0.4 inadvertently changed the strict `\u003c` comparison to `\u003c=`, introducing the vulnerability. Version 0.1.0-rc.4 fixes the issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ML-DSA Signature Verification Accepts Signatures with Repeated Hint Indices","id":"CVE-2026-24850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":11,"next":{"headline":"OpenFGA Improper Policy Enforcement","id":"CVE-2026-24851"},"packages":[{"ecosystem":"crates.io","fixed":["0.1.0-rc.4"],"introduced":["0.0.4"],"last_affected":[],"package":"ml-dsa","purl":null,"source":"GHSA-5x2r-hc65-25f9"},{"ecosystem":"crates.io","fixed":["0.1.0-rc.4"],"introduced":["0.0.4"],"last_affected":[],"package":"ml-dsa","purl":"pkg:cargo/ml-dsa","source":"GHSA-5x2r-hc65-25f9"}],"prev":{"headline":"OpenEMR Arbitrary File Read Vulnerability","id":"CVE-2026-24849"},"products":["signatures"],"published":"2026-01-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-28","vendors":["RustCrypto"]},"summary":"Attackers can bypass signature verification in the ML-DSA Rust library by submitting signatures with duplicate hint indices, violating FIPS 204 standards.","url":"https://insights.sbomify.com/CVE-2026-24850/"}