# CVE-2026-24850: ML-DSA Signature Verification Accepts Signatures with Repeated Hint Indices

> Attackers can bypass signature verification in the ML-DSA Rust library by submitting signatures with duplicate hint indices, violating FIPS 204 standards.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 28 Jan 2026
- **Also known as:** GHSA-5x2r-hc65-25f9

## What is CVE-2026-24850?

CVE-2026-24850 is a medium-severity vulnerability in RustCrypto signatures, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ML-DSA crate is a Rust implementation of the Module-Lattice-Based Digital Signature Standard (ML-DSA). Starting in version 0.0.4 and prior to version 0.1.0-rc.4, the ML-DSA signature verification implementation in the RustCrypto `ml-dsa` crate incorrectly accepts signatures with repeated (duplicate) hint indices. According to the ML-DSA specification (FIPS 204 / RFC 9881), hint indices within each polynomial must be **strictly increasing**. The current implementation uses a non-strict monotonic check (`<=` instead of `<`), allowing duplicate indices. This is a regression bug. The original implementation was correct, but a commit in version 0.0.4 inadvertently changed the strict `<` comparison to `<=`, introducing the vulnerability. Version 0.1.0-rc.4 fixes the issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-24850?

2 open source packages ship an affected version, including ml-dsa.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ml-dsa` | crates.io | From 0.0.4 | 0.1.0-rc.4 |
| `ml-dsa` | crates.io | From 0.0.4 | 0.1.0-rc.4 |

## How do I fix CVE-2026-24850?

Upgrade ml-dsa to 0.1.0-rc.4 or later.

## Is CVE-2026-24850 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24850 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24850 and fix it if it is affected.

What it is: CVE-2026-24850 is a medium-severity vulnerability in RustCrypto signatures, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24850 exists.

Affected packages and fixed versions:
- ml-dsa (crates.io): affected from 0.0.4; fixed in 0.1.0-rc.4
- ml-dsa (crates.io): affected from 0.0.4; fixed in 0.1.0-rc.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24850/ (Markdown: https://insights.sbomify.com/CVE-2026-24850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24850
- OSV: https://osv.dev/vulnerability/CVE-2026-24850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24850/
Summaries are generated and may contain mistakes; the official description above is the record.
