# CVE-2026-24851: OpenFGA Improper Policy Enforcement

> Attackers can bypass authorization checks in OpenFGA under specific model and tuple configurations, gaining unauthorized access to protected resources.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-jq9f-gm9w-rwm9, GO-2026-4446, MINI-335x-8qrr-94j9, MINI-76h4-mm8p-86vp, MINI-84p7-43cv-8f9p, MINI-85hf-m9pc-2fq5, MINI-8mj8-gx37-fg36, MINI-92f6-v6hv-9hrc, MINI-f5qw-pgrh-hrwc, MINI-gcpc-gx6q-4mrv, MINI-hq6m-m428-2x95, MINI-jvpq-g35q-48h4, MINI-r6gj-cq9w-jhrh, MINI-v4h5-xvfp-wqqw, MINI-vhp3-gmxj-qjf8, MINI-vqpm-c5fw-4j46

## What is CVE-2026-24851?

CVE-2026-24851 is a medium-severity missing authorization vulnerability in openfga, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22<= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. The vulnerability requires a model that has a a relation directly assignable by a type bound public access and assignable by type bound non-public access, a tuple assigned for the relation that is a type bound public access, a tuple assigned for the same object with the same relation that is not type bound public access, and a tuple assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access. This vulnerability is fixed in v1.11.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-24851?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 1.8.5 | 1.11.3 |
| `github.com/openfga/openfga` | Go | From 1.8.5 | 1.11.3 |
| `github.com/openfga/openfga` | Go | From 1.8.5 | 1.11.3 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2026-24851?

Upgrade github.com/openfga/openfga to 1.11.3 or later.

## Is CVE-2026-24851 being exploited?

There is no known exploitation of CVE-2026-24851 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)
- [CVE-2025-46331](https://insights.sbomify.com/CVE-2025-46331/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24851 and fix it if it is affected.

What it is: CVE-2026-24851 is a medium-severity missing authorization vulnerability in openfga, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24851 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 1.8.5; fixed in 1.11.3
- github.com/openfga/openfga (Go): affected from 1.8.5; fixed in 1.11.3
- github.com/openfga/openfga (Go): affected from 1.8.5; fixed in 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24851/ (Markdown: https://insights.sbomify.com/CVE-2026-24851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24851
- OSV: https://osv.dev/vulnerability/CVE-2026-24851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24851/
Summaries are generated and may contain mistakes; the official description above is the record.
