# CVE-2026-24853: Caido has an insufficient patch for DNS rebind leading to RCE

> Attackers can bypass DNS rebinding protections via X-Forwarded-Host header injection, leading to remote code execution in Caido.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Feb 2026
- **Updated:** 17 Feb 2026
- **Also known as:** GHSA-3q5q-p8vj-8783

## What is CVE-2026-24853?

CVE-2026-24853 is a high-severity vulnerability in caido, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caido is a web security auditing toolkit. Prior to 0.55.0, Caido blocks non whitelisted domains to reach out through the 8080 port, and shows Host/IP is not allowed to connect to Caido on all endpoints. But this is bypassable by injecting a X-Forwarded-Host: 127.0.0.1:8080 header. This vulnerability is fixed in 0.55.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-24853?

It affects 1 product.


Products: Caido Caido.

## How do I fix CVE-2026-24853?

No fix has been published for CVE-2026-24853 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-24853 being exploited?

There is no known exploitation of CVE-2026-24853 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24853 and fix it if it is affected.

What it is: CVE-2026-24853 is a high-severity vulnerability in caido, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24853 in the wild and no public exploit code.

Affected product: caido. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24853/ (Markdown: https://insights.sbomify.com/CVE-2026-24853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24853
- OSV: https://osv.dev/vulnerability/CVE-2026-24853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24853/
Summaries are generated and may contain mistakes; the official description above is the record.
