CVE-2026-24889 soroban-sdk has overflow in Bytes::slice, Vec::slice, GenRange::gen_range for u64
Integer overflow in slice and random generation methods can corrupt contract state if overflow checks are disabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24889?
CVE-2026-24889 is a medium-severity vulnerability in stellar rs-soroban-sdk, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
soroban-sdk is a Rust SDK for Soroban contracts. Arithmetic overflow can be triggered in the `Bytes::slice`, `Vec::slice`, and `Prng::gen_range` (for `u64`) methods in the `soroban-sdk` in versions up to and including `25.0.1`, `23.5.1`, and `25.0.2`. Contracts that pass user-controlled or computed range bounds to `Bytes::slice`, `Vec::slice`, or `Prng::gen_range` may silently operate on incorrect data ranges or generate random numbers from an unintended range, potentially resulting in corrupted contract state. Note that the best practice when using the `soroban-sdk` and building Soroban contracts is to always enable `overflow-checks = true`. The `stellar contract init` tool that prepares the boiler plate for a Soroban contract, as well as all examples and docs, encourage the use of configuring `overflow-checks = true` on `release` profiles so that these arithmetic operations fail rather than silently wrap. Contracts are only impacted if they use `overflow-checks = false` either explicitly or implicitly. It is anticipated the majority of contracts could not be impacted because the best practice encouraged by tooling is to enable `overflow-checks`. The fix available in `25.0.1`, `23.5.1`, and `25.0.2` replaces bare arithmetic with `checked_add` / `checked_sub`, ensuring overflow traps regardless of the `overflow-checks` profile setting. As a workaround, contract workspaces can be configured with a profile available in the GitHub Securtity Advisory to enable overflow checks on the arithmetic operations. This is the best practice when developing Soroban contracts, and the default if using the contract boilerplate generated using `stellar contract init`. Alternatively, contracts can validate range bounds before passing them to `slice` or `gen_range` to ensure the conversions cannot overflow.
Weakness: CWE-190
Which versions are affected by CVE-2026-24889?
6 open source packages ship an affected version, including soroban-sdk. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
soroban-sdk crates.io | All versions | 22.0.9 |
soroban-sdk crates.io | All versions | 22.0.9 |
soroban-sdk crates.io | From 23.0.0 | 23.5.1 |
soroban-sdk crates.io | From 23.0.0 | 23.5.1 |
soroban-sdk crates.io | From 25.0.0 | 25.0.2 |
soroban-sdk crates.io | From 25.0.0 | 25.0.2 |
Products include Stellar Rs-Soroban-Sdk.
How do I fix CVE-2026-24889?
Upgrade soroban-sdk to a fixed version for your release line: 22.0.9, 23.5.1 or 25.0.2.
Is CVE-2026-24889 being exploited?
There is no known exploitation of CVE-2026-24889 in the wild and no public exploit code.
Other vulnerabilities in stellar rs-soroban-sdk
Sources
Also known as GHSA-96xm-fv9w-pf3f.