# CVE-2026-24889: soroban-sdk has overflow in Bytes::slice, Vec::slice, GenRange::gen_range for u64

> Integer overflow in slice and random generation methods can corrupt contract state if overflow checks are disabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2026
- **Updated:** 29 Jan 2026
- **Also known as:** GHSA-96xm-fv9w-pf3f

## What is CVE-2026-24889?

CVE-2026-24889 is a medium-severity vulnerability in stellar rs-soroban-sdk, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

soroban-sdk is a Rust SDK for Soroban contracts. Arithmetic overflow can be triggered in the `Bytes::slice`, `Vec::slice`, and `Prng::gen_range` (for `u64`) methods in the `soroban-sdk` in versions up to and including `25.0.1`, `23.5.1`, and `25.0.2`. Contracts that pass user-controlled or computed range bounds to `Bytes::slice`, `Vec::slice`, or `Prng::gen_range` may silently operate on incorrect data ranges or generate random numbers from an unintended range, potentially resulting in corrupted contract state. Note that the best practice when using the `soroban-sdk` and building Soroban contracts is to always enable `overflow-checks = true`. The `stellar contract init` tool that prepares the boiler plate for a Soroban contract, as well as all examples and docs, encourage the use of configuring `overflow-checks = true` on `release` profiles so that these arithmetic operations fail rather than silently wrap. Contracts are only impacted if they use `overflow-checks = false` either explicitly or implicitly. It is anticipated the majority of contracts could not be impacted because the best practice encouraged by tooling is to enable `overflow-checks`. The fix available in `25.0.1`, `23.5.1`, and `25.0.2` replaces bare arithmetic with `checked_add` / `checked_sub`, ensuring overflow traps regardless of the `overflow-checks` profile setting. As a workaround, contract workspaces can be configured with a profile available in the GitHub Securtity Advisory to enable overflow checks on the arithmetic operations. This is the best practice when developing Soroban contracts, and the default if using the contract boilerplate generated using `stellar contract init`. Alternatively, contracts can validate range bounds before passing them to `slice` or `gen_range` to ensure the conversions cannot overflow.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-24889?

6 open source packages ship an affected version, including soroban-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `soroban-sdk` | crates.io | All versions | 22.0.9 |
| `soroban-sdk` | crates.io | All versions | 22.0.9 |
| `soroban-sdk` | crates.io | From 23.0.0 | 23.5.1 |
| `soroban-sdk` | crates.io | From 23.0.0 | 23.5.1 |
| `soroban-sdk` | crates.io | From 25.0.0 | 25.0.2 |
| `soroban-sdk` | crates.io | From 25.0.0 | 25.0.2 |

Products: Stellar Rs-Soroban-Sdk.

## How do I fix CVE-2026-24889?

Upgrade soroban-sdk to a fixed version for your release line: 22.0.9, 23.5.1 or 25.0.2.

## Is CVE-2026-24889 being exploited?

There is no known exploitation of CVE-2026-24889 in the wild and no public exploit code.

## Other vulnerabilities in stellar rs-soroban-sdk

- [CVE-2026-26267](https://insights.sbomify.com/CVE-2026-26267/): rs-soroban-sdk #[contractimpl] macro calls inherent function instead of trait function when names collide (high 7.5)
- [CVE-2026-32322](https://insights.sbomify.com/CVE-2026-32322/): soroban-sdk: `Fr` scalar field equality comparison bypasses modular reduction (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24889 and fix it if it is affected.

What it is: CVE-2026-24889 is a medium-severity vulnerability in stellar rs-soroban-sdk, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24889 in the wild and no public exploit code.

Affected packages and fixed versions:
- soroban-sdk (crates.io): affected all versions; fixed in 22.0.9
- soroban-sdk (crates.io): affected all versions; fixed in 22.0.9
- soroban-sdk (crates.io): affected from 23.0.0; fixed in 23.5.1
- soroban-sdk (crates.io): affected from 23.0.0; fixed in 23.5.1
- soroban-sdk (crates.io): affected from 25.0.0; fixed in 25.0.2
- soroban-sdk (crates.io): affected from 25.0.0; fixed in 25.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24889/ (Markdown: https://insights.sbomify.com/CVE-2026-24889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24889
- OSV: https://osv.dev/vulnerability/CVE-2026-24889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24889/
Summaries are generated and may contain mistakes; the official description above is the record.
